FAT tables cannot be read- WD HDD drive

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
Avgis
Posts: 1
Joined: 02 Mar 2013, 17:21

FAT tables cannot be read- WD HDD drive

#1 Post by Avgis » 02 Mar 2013, 17:38

This is an extrenal drive FAT32 file system. All of the sudden the data was not accebile (windows (7)prompted me to format disk as could not recognize it). I run chkdisk (maybe a mistake) and it could find no files Error msg: "There are no readable file allocation tables (FAT)". I runTestdisk, which did find a partition, which looked to be correct but could not any read files (Error msg: "No filesystem found, filesystem may be damaged"). I then under the Advanced option run Boot. I get that Boot Sector and Bacup Bootsectors are OK and sectors are identical.

What can I do next? Could I run repair FAT? Is this dangerous for data loss (a lot of data on drive)?

Any help very much appreciated
Avgis

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4183
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: FAT tables cannot be read- WD HDD drive

#2 Post by cgrenier » 26 Mar 2013, 08:42

Run PhotoRec, enable the expert mode in Options, select the partition, start a recovery, choose [Whole], try the unformat option, use the default options otherwise.
Good luck

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest