PhotoRec - STATUS_ACCESS_VIOLATION Topic is solved

Using PhotoRec to recover lost data
Locked
Message
Author
flok
Posts: 2
Joined: 02 Apr 2013, 20:48

PhotoRec - STATUS_ACCESS_VIOLATION  Topic is solved

#1 Post by flok » 02 Apr 2013, 22:47

Hi,

while recovering my files, PhotoRec suddenly closes.
The following information is contained in photorec_win.exe.stackdump:

Exception: STATUS_ACCESS_VIOLATION at eip=611298C5
eax=0A0A0A0A ebx=01010101 ecx=FFF861FC edx=F5F5F5F5 esi=7EF26202 edi=7EFA0000
ebp=00289278 esp=00289270 program=<userdirectory>\Downloads\testdisk-6.14-WIP\photorec_win.exe, pid 12788, thread main
cs=0023 ds=002B es=002B fs=0053 gs=002B ss=002B
Stack trace:
Frame Function Args
00289278 611298C5 (7EF26202, 0000000A, FFFFFFFE, 77BDFBDA)
End of stack trace

Additional information:
I try to recover files on a western digital 2 TB external disc, which was formatted in NTFS and is now formatted in FAT32 (with 42 files on drive), whereas I want to recover files of the previous NTFS system.

Options in PhotoRec:
/dev/sdc partition_i386,1blocksize,512,fileopt,options,paranoid_bf,keep_corrupted_file,lowmem,wholespace,search,status=ext2_off,125729429,inter

OS: Windows 7 64 bit
PhotoRec: 6.14 32 bit (the 64 bit version crashes if I try to start it)

The recovered files are saved on another external disc.



Can you please help?



Addition:
This only occured for a few specific sectors.
After restarting PhotoRec and resuming the process a few times, it continued without the exception!

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3754
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: PhotoRec - STATUS_ACCESS_VIOLATION

#2 Post by cgrenier » 13 Apr 2013, 16:50

I have uploaded a new 6.14-WIP for Windows 64 bits. Do you still have the problem ?
Concerning the 32 bit version, have you been able to detect the kind of file photorec was trying to recover ? (latest file in recup_dir.*)

flok
Posts: 2
Joined: 02 Apr 2013, 20:48

Re: PhotoRec - STATUS_ACCESS_VIOLATION

#3 Post by flok » 14 Apr 2013, 10:44

Hi,
as I said, this only occured for a few sectors, then the program didn't close.
Yes, I recovered the files successfully!

Locked

Who is online

Users browsing this forum: No registered users and 1 guest