"Testdisk has stopped working" Topic is solved

How to use TestDisk to recover lost partition
Locked
Message
Author
slaptop
Posts: 2
Joined: 04 Apr 2013, 21:57

"Testdisk has stopped working"

#1 Post by slaptop » 04 Apr 2013, 22:38

Testdisk fails to get up and running with message
Testdisk has stopped working
.
I've run-as administrator (root on this box) on Windows 7 home premium 64bit having moved the extracted folder to root\documents.

The application eventlog has 2 entries - below
Many thanks

Event ID 1000
Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: testdisk_win.exe
P2: 6.14.0.0
P3: 515870cb
P4: pdcurses.dll
P5: 0.0.0.0
P6: 5009dd30
P7: c0000005
P8: 0000000000003675
P9:
P10:

Attached files:
C:\Users\root\AppData\Local\Temp\WER2631.tmp.WERInternalMetadata.xml
C:\Users\root\AppData\Local\Temp\WER59EE.tmp.appcompat.txt
C:\Users\root\AppData\Local\Temp\WER5A1E.tmp.hdmp
C:\Users\root\AppData\Local\Temp\WER5A7C.tmp.mdmp

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_testdisk_win.exe_aa6b7c57d28bf3cb39828bb888b5dc7898e_cab_0e435ab8

Analysis symbol:
Rechecking for solution: 0
Report Id: 9de2da84-9d6c-11e2-ac5e-c80aa961f81c
Report Status: 36


Followed by event id 1001

Faulting application name: testdisk_win.exe, version: 6.14.0.0, time stamp: 0x515870cb
Faulting module name: pdcurses.dll, version: 0.0.0.0, time stamp: 0x5009dd30
Exception code: 0xc0000005
Fault offset: 0x0000000000003675
Faulting process id: 0x8b0
Faulting application start time: 0x01ce317960266140
Faulting application path: C:\Users\root\Documents\testdisk-6.14-WIP.win64\testdisk-6.14-WIP\testdisk_win.exe
Faulting module path: C:\Users\root\Documents\testdisk-6.14-WIP.win64\testdisk-6.14-WIP\pdcurses.dll
Report Id: 9de2da84-9d6c-11e2-ac5e-c80aa961f81c

Sponsored links

User avatar
Fiona
Posts: 2836
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: "Testdisk has stopped working"  Topic is solved

#2 Post by Fiona » 05 Apr 2013, 08:51

Currently it's not recommedned to use the 64 bit version.
It's only intended on computer which have no 32 bit support like Itanium etc..
Windows 7 has 32bit support through WOW64 (windows on windows is the 32bit emulation).
Would it be possible to repeat your diagnose using testdisk 6.14WIP 32bit?

slaptop
Posts: 2
Joined: 04 Apr 2013, 21:57

Re: "Testdisk has stopped working"

#3 Post by slaptop » 05 Apr 2013, 16:58

Many thanks Fiona.
I came to the same conclusion in the early hours of the morning and yes the standard 32bit worked well.
I didn't know that about Itanium systems. Slightly, embarrasing for someone who a few years ago designed the 2nd largest Superdome estate in the world. (A refresh of a pa-risc chips based estate).

The good news is that others who hit this and have the same event log entries will now also have the circumvention.

More good news is that my old 595gig external usb disk's raw partition was found and yes the bs was bad and so was the backup. So I hoped it had been quick formated by mistake on plugin sometime during the past 4 years of shelf life and took the rebuild option, which trundled through a search.

OK own up time....
The bad news is that while I was watching the sectors count thru to 9 hundred trillion, my brain kicked back into life.
I had loads of camcorder tapes converted to that drive, all family stuff I'd want to keep safe.
Hold on, maybe I'd used Truecrypt on it! and at device container level not encrypted file level.
So it looked like a raw partition with corrupted BS & mirror because it IS a raw partition that doesn't use a bootsector (maybe a clue for your forum in the future).

I killed the rebuild ( nine tenths thru) before it actually wrote anything, ran up truecript and put in my normal encryption password and bingo another volume appeared in explorer.

Moral of the story....use your brain before deploying powerful low level tools.

BTW truecrypt is a brilliant opensource product that has never let me down.
http://www.truecrypt.org/docs/

Many thanks
Bill

Locked

Who is online

Users browsing this forum: No registered users and 2 guests