Write partition structure, but nothing happens

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 3
Joined: 14 Apr 2013, 04:09

Write partition structure, but nothing happens

#1 Post by Gil42 »


I'm trying to fix an external drive that is displayed as RAW on windows. I think I am getting the steps on TestDisk right, but even if I choose "write partition structure on disk" and reboot the computer, nothing happens! It's still "RAW" and if I run TestDisk again, it shows the same wrong partition structure on quick search, as if nothing changed on the drive. I'm guessing I need to confirm the operation somehow.

Any help is much appreciated!

Further information:
It's a 1TB NTFS external drive, it wont mount on Windows and is shown as "RAW" by disk manager. On Linux, it opens normally, except for some random corrupted files. I'm running TestDisk from Linux. Quick search shows me a wrong FAT32 LBA bootable partition, then deeper search finds the correct NTFS partion, with correct file listing. It's shown as Deleted, I set it to Primary, and proceed to "write partition structure on disk". Confirm with "y", then [Ok], quit two times to exit TestDisk and reboot the computer. Nothing happens, though. Everything will see the drive the same way, no changes are made to it!