Partition Raid0 trouvé mais non récupérable

Comment utiliser TestDisk pour récupérer une partition perdue
Post Reply
Message
Author
User avatar
vsix
Posts: 12
Joined: 28 Apr 2013, 23:16
Location: Clermont-Ferrand - France

Partition Raid0 trouvé mais non récupérable

#1 Post by vsix » 28 Apr 2013, 23:34

Bonjour,

J'ai un petit soucis concernant mon raid0 de deux HDD de 2To. Depuis mon remplacement de carte mère, ma partition n'était plus accessible (raid en failed, avec un des deux disques en mode non-member disk). J'ai trouvé un petit tuto sur un autre forum conseillant de réinitialiser tous les disque en non-raid et de recréer la grappe avec les même config que la précédente pour ensuite récupérer la partition grâce à Testdisk. Sauf que malheureusement, Testdisk retrouve bien la partition mais ne peu pas la réparer... Il y a quelque chose que j'ai loupé? Peut être dois-je tenter de changer l'ordre de branchement des DD?

Merci d'avance de votre aide :-)

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3458
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Partition Raid0 trouvé mais non récupérable

#2 Post by cgrenier » 30 Apr 2013, 07:11

Quel message affiche TestDisk ? Pourquoi ne peut-il pas récupérer la partition ?

User avatar
vsix
Posts: 12
Joined: 28 Apr 2013, 23:16
Location: Clermont-Ferrand - France

Re: Partition Raid0 trouvé mais non récupérable

#3 Post by vsix » 30 Apr 2013, 09:07

Désolé, j'avais oublié de mentionner ce détails, en fait il me fait un "seems too small".

J'ai un peu avancé dans la récupération de mes données mais toujours impossible de réparer la partition :
- J'ai commencé par échanger les câbles SATA, et depuis ma partition est détecté en quelques secondes mais toujours ce problème de "seems too small".
- Par défaut, mon raid0 est détecté à 486398 cylindres, la partition commence à 264000 à peu près mais termine à environ 7800000000 (je ne peux pas fournir les valeurs exactes pour le moment, je posterai des screens dans la journée).

=> Chose bizarre, j'ai remarqué qu'en changeant le nombre de cylindre à 486401, je peux accéder aux fichiers (dont je viens de sauvegarder les plus importants) de ma partition perdue et même tenter un write, qui échoue bien sûr :cry: .
Last edited by vsix on 30 Apr 2013, 15:45, edited 2 times in total.

User avatar
vsix
Posts: 12
Joined: 28 Apr 2013, 23:16
Location: Clermont-Ferrand - France

Re: Partition Raid0 trouvé mais non récupérable

#4 Post by vsix » 30 Apr 2013, 12:09

Voici les étapes que j'ai suivi :

Essai sans toucher aux paramètres calculés par TestDisk (486398 cylindres) :
Image
Image

Essai avec un nombre de cylindres à 486401 au lieu de 486398 :
Image
Image
Liste des fichiers ok, les fichiers copiés sur mon DD externe ne sont pas corrompues :
Image
Mais impossible de rétablir la partition :
Image

En théorie, il me serait possible de sauvegarder toutes mes données, seulement j'ai plus de 3To sur ce raid et je n'ai pas de disque dur externe aussi volumineux...

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 0 guests