Testdisk RepairMFT lost the file structure of the disc

Using TestDisk to repair the filesystem
Post Reply
Message
Author
pakkers
Posts: 2
Joined: 12 Jun 2013, 08:40

Testdisk RepairMFT lost the file structure of the disc

#1 Post by pakkers » 12 Jun 2013, 09:29

Hi, I want to tell you a problem with my disc. (I don't speak english very well, sorry).

My laptop is a Acer Aspire with HD 500Gb y some partitions
- Partition Restore 15 Gb (It's manufacturer partition to come back the laptop to original state)
- Partition Windows Loader 100 Mb
- Partition Windows 7 430 Gn Primary.
- Particion Extended
- Logic with Linux 30 Gigas
- Logic Swap Memory to Linux.

My problem started when I tried to install another linux distribution and I made mistake erasing partition Windows Loader and Windows 7 don't ran.

In that moment, I test many of things
- I tried restore MBR from Windows Restore CD ... without results
- I copied tried restore MBR from Windows Restore CD ... without results
- From the manufacturer's restore partition I copy my data and try to fix it but nothing.
- From Linux I ran ms-sys to try recover MBR ... without results.
- From linux I tried to repair MBR with testdisk ... without results.
- I tried to install MBR in Windows 7 partition and made bootable this partition to start pc on it ... without results.

Next step was finally broke my filesystem. I was desesperate and use other time testdisk and use option RepairMFT on Windows 7 partition. In that moment, all my files and directories are missing. Only have a few files and directories
but I don't recognize them.

And now ... How can recover my original MFT?

I have some ideas, but I'm afraid to test any of them ...

- Windows Restore CD and test
chkdsk /R /f or
chkdsk <letter of windows 7 partition> /R /f
- Testdisk and RepairMFT one more time
- Use ntfsprogs from linux
- Use Testdisk Windows Edition and test ... But I would need install windows 7 in a USB like a Operating System not like a Windows Restor. I heard that you can install Windows 8 or 7 in a USB with Windows to Go. I'm on it.

As you see, it's some complex and I'm lost, I would appreciate your help because I was looking for solutions in many "foros" like this and in Google and I can't see one solution who works 100%.

Thanks very much for your attention. I wait for news.

PD: I can post this problem in spanish if someone don't understandme

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests