Stopping and continuing recovery

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
tuukka
Posts: 1
Joined: 30 Mar 2012, 18:10

Stopping and continuing recovery

#1 Post by tuukka » 30 Mar 2012, 18:14

Dear forum,
Is it possible to stop Photorec with e.g. SIGINT and have it continue the recovery later from where it was?

Sponsored links

User avatar
Fiona
Posts: 2836
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: Stopping and continuing recovery

#2 Post by Fiona » 31 Mar 2012, 20:49

Yes, it's possible.
Just stop it.
Next session, you will be asked to continue.

Timmi
Posts: 2
Joined: 06 Jul 2018, 17:14

Re: Stopping and continuing recovery

#3 Post by Timmi » 06 Jul 2018, 18:08

(sorry to revive a 2012 post, but this one was right at the top of google search results)

2018: I see photorec in the process of recovering files (but I realize I'd like to shrink the partition and create a new one in the unused portion, and recover only from that section), so I'd like to stop the process.
I see the [STOP] "button" at the bottom. But HOW do you use that? I've tried arrows and Tab, + spacebar, and they don't activate the button, the mouse doesn't activate the button, I've pressed S...
Sorry, but I can't figure out how to make it stop. Finally I closed the terminal and it terminated the process, but there seems to be another way.

User avatar
cgrenier
Site Admin
Posts: 4290
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Stopping and continuing recovery

#4 Post by cgrenier » 07 Jul 2018, 10:52

As Stop is already selected, you only had to press Enter.
You should be able to resume the recovery if you restart PhotoRec.

Post Reply

Who is online

Users browsing this forum: Google Adsense [Bot] and 5 guests