partitioning problem

How to use TestDisk to recover lost partition
Post Reply
Message
Author
pjmmartins
Posts: 1
Joined: 27 Jul 2013, 17:02

partitioning problem

#1 Post by pjmmartins » 27 Jul 2013, 17:38

Hi,

I have an external Hard Drive which came with MBR partition table. I used to have a first partition with a ntfs partition where I had my Windows files and a hfs partition with my Mac files. Some days ago, i tried to create another hfs partiton. So, I went to my windows machine and resized the ntfs partition and left free space for my new partition. When I then formatted this left space in my Macbook as a hfs partition, this new partition merged with the previous hfs partition that I used to have there. Since this new partition kept the size that was left empty, I couldn't realize what happened to the previous hfs partition. The Hard Drive had 2TB but 750GB were missing. Disk utility just showed the ntfs and the new hfs partition. The other one disappeared. Doing some research, I realized that testdisk was my salvation to recover the lost and missing hfs partition. And so it was, the lost partition appeared after doing a quick analysis of the external hard drive, whose output I show at the bottom of this post. The lost partition was identified as:

HFS 1512761834 3301759123 1788997290 [~S'D m ^B ~I~C ^V #>].

My next step was to backup my windows files in my ntfs partition and then using pdisk in my macbook to create a new partition table in the external hard drive, giving the correct blocks to the lost partition. This partition shows up now as disk1s3 but I can't mount it and when plug the external hard drive to the macbook, it gives me an error. It complains about invalid volume header. Is there any chance that I can recover the data from my lost hfs partition?

Thank you in advance.

Best Regards,

Paulo Martins


TestDisk 6.14-WIP, Data Recovery Utility, May 2013
Christophe GRENIER <grenier@cgsecurity.org>
http://www.cgsecurity.org

Disk /dev/rdisk2 - 2000 GB / 1862 GiB - 3906963456 sectors (RO)
Partition Start End Size in sectors
>* HPFS - NTFS 1 1424997625 1424997625 [My Book]
HFS 1424997693 2332621932 907624240
HFS 1424997695 2332621934 907624240
HFS 1512761834 3301759123 1788997290 [~S'D m ^B ~I~C ^V #>]
HFS 2332628988 2414546939 81917952
HPFS - NTFS 2424006748 2491094124 67087377
FAT16 <32M 2800607149 3277225929 476618781


Structure: Ok. Use Up/Down Arrow keys to select partition.
Use Left/Right Arrow keys to CHANGE partition characteristics:
*=Primary bootable P=Primary L=Logical E=Extended D=Deleted
Keys A: add partition, L: load backup, T: change type, P: list files,
Enter: to continue
NTFS, blocksize=4096, 729 GB / 679 GiB

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests