Is Photorec running?

Using PhotoRec to recover lost data
Post Reply
Message
Author
thadyq
Posts: 5
Joined: 13 Jun 2013, 11:36

Is Photorec running?

#1 Post by thadyq » 06 Aug 2013, 06:57

Hi,
I'm using Photorec 6-14 to recover files from a failed 2tb external hard drive. Here's a picture of the screen after a day and a half or more after pressing Enter.
screenshot.png
screenshot.png (16.68 KiB) Viewed 2374 times
My question is, how to know if Photorec is actually running. Have tried sudo fs_usage | grep photorec in another shell to try get a view of the log but the screen is blank. Also, If I try to quit Photorec with Control+C or q, nothing happens. I could quit Terminal and terminate the project but don't want to do that, not yet anyway.
Just wondering if this is normal and you just have to be patient and wait a few days or weeks for things to develop.
The Testdisk and Photorec folder is on another external hard drive on which I hope to put the recovered files.
I'm a newbie to Linux and Photorec so please forgive my ignorance.
Regards

Sponsored links

DSpider
Posts: 23
Joined: 29 Jul 2013, 10:41

Re: Is Photorec running?

#2 Post by DSpider » 06 Aug 2013, 09:56

Hi thadyq,

Well in the sceenshot you gave, it is running. You have to select [proceed] and enter. After that, you have to choose the filesystem where the files you want to recover were, and then choose the target folder where to save them.

You can see it when it is running !!

thadyq
Posts: 5
Joined: 13 Jun 2013, 11:36

Re: Is Photorec running?

#3 Post by thadyq » 06 Aug 2013, 11:43

Hi DSpider
Thanks for the response. In fact, I did select Proceed and pressed Enter and the screenshot is taken after that. It has been like that for nearly 2 days now. In fact, after pressing Enter, nothing seemed to happen, and the arrow keys don't work, and I can't do anything except close Terminal and terminate.

After that, you have to choose the filesystem where the files you want to recover were, and then choose the target folder where to save them.
None of those options became available after pressing Enter.
Regards

DSpider
Posts: 23
Joined: 29 Jul 2013, 10:41

Re: Is Photorec running?

#4 Post by DSpider » 06 Aug 2013, 11:59

This is weird, i would like to say that it is a version problem but i have just check it out and it seems like the 6.14 is stable since July 30th. I will suggest you to try the version before, i don't it would help but just to be fixed.

I will wait for the result.

thadyq
Posts: 5
Joined: 13 Jun 2013, 11:36

Re: Is Photorec running?

#5 Post by thadyq » 06 Aug 2013, 14:14

Okay, I'll try that -- or try 6-14 on a different computer, an eMac. The only way I can quit Photorec is to terminate the project by shutting down Terminal. Do you think that is OK to do or might it do some further damage to the failed hard disk?

DSpider
Posts: 23
Joined: 29 Jul 2013, 10:41

Re: Is Photorec running?

#6 Post by DSpider » 06 Aug 2013, 14:59

Do you think that is OK to do or might it do some further damage to the failed hard disk?
I don't think so, Photorec does not do any modification on the partition table or the filesystem but only try to recover files.

thadyq
Posts: 5
Joined: 13 Jun 2013, 11:36

Re: Is Photorec running?

#7 Post by thadyq » 08 Aug 2013, 03:21

Good news, it's working now.
I restarted the project on the eMac, which has a higher processor speed than the Mac Mini I was using before.
One thing I did which may have helped was to open Photorec, not by double-clicking the file inside the Testdisk-6.14 folder, but by opening Terminal, doing cd (space), dragging the Testdisk folder into the Terminal window and pressing return. Then ./ photorec opened it. From there, the options came up and now it's running.
Here's a snapshot of where it's at now.
Disk /dev/rdisk2 - 2199 GB / 2048 GiB (RO)
Partition Start End Size in sectors
P Unknown 0 0 1 4294967295 0 1 4294967296


Pass 0 - Reading sector 21528/4294967296, 0/10 headers found
Elapsed time 2h06m34s - Estimated time to completion 420844h55m20
Error reading sector 21528
As you see, it's a big disk and will take some time but I hope less than 400,000 hours :roll:
Will keep you posted on the progress.
Regards

DSpider
Posts: 23
Joined: 29 Jul 2013, 10:41

Re: Is Photorec running?

#8 Post by DSpider » 08 Aug 2013, 11:17

Happy for you,

I'll wait news from you.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests