Testdisk finds partition but can't restore it

How to use TestDisk to recover lost partition
Post Reply
Message
Author
monkeymania
Posts: 2
Joined: 06 Aug 2013, 12:52

Testdisk finds partition but can't restore it

#1 Post by monkeymania » 06 Aug 2013, 13:19

Hi,

I hope someone can help out :? . I have used test disk to try to recover a partition. I initially had an ext4 partition which filled an entire HDD (2TB).

If I run test disk it does not find it initially. Then if I "search deeper" it comes up [HTSData] - see img. Image

The problem is that I don't get any chance to write the partition. Testdisk comes up blank at the end of the deeper search.

Can I simply recreate this partition using the start/end of the partition found? I have tried to "add" in testdisk but the Cylinders/Head/Sectors do not give me the same numbers seen in the deeper search. When I try to "add" nothing happens and I still cannot write.

The [again] recovered partitions have been my failed efforts to fix so far. To begin with they were not there and the numbers for {HTSData] were identical to what they are now.

The data is still there (photorec works) but trying to sort out 2TB of data with no filenames/directory structure will be all but impossible.

Thanks,

Jon

Sponsored links


monkeymania
Posts: 2
Joined: 06 Aug 2013, 12:52

Re: Testdisk finds partition but can't restore it

#3 Post by monkeymania » 07 Aug 2013, 10:14

Hi Dspider,

I think it is not possible to undelete files without a working partition. I'm going to look though to make sure!

Thanks,

Jon

DSpider
Posts: 23
Joined: 29 Jul 2013, 10:41

Re: Testdisk finds partition but can't restore it

#4 Post by DSpider » 07 Aug 2013, 10:59

I agree.

Can you give the options you selected before starting Testdisk analyses ?

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests