WD My Passport 1TB Weird issue - Almost dead drive

How to use TestDisk to recover lost partition
Post Reply
Message
Author
seitec200
Posts: 4
Joined: 06 Aug 2013, 16:49

WD My Passport 1TB Weird issue - Almost dead drive

#1 Post by seitec200 » 06 Aug 2013, 16:55

3 days ago my 1 TB external USB My Passport failed and was shown as 0 bytes Raw data and in Windows 7 I get the 'Format disk' window. Of, course since then I haven't done anything destructive to the drive like fixboot etc. I'd also like to point out that there are no clicking or weird noises from the drive which seems to spin normally.

I have done almost everything than can be done in these cases like, testing in different computers, changing the cable and of course tried about 20 data recovery application including Testdisk and Photorec via Windows and Linux boot cd.

The drive was visible in some apps while in other not. On those apps that it was visible I got more or less an error instantly saying the drive is empty and no files can be recovered. Testdisk deep scan the disk and gives errors on all sectors, while in the ends finds nothing.

The weird part is that after 2 days and nights and while running testdisk I saw for a brief second the autoplay window. A few minutes later the autoplay window showed up again and stayed there!! Acting in crazy quick mode I started copying the most valuable files and after about 15 minutes it failed again...

Since then I am trying pluging in and out... running tools of all sorts... just to find out what triggered my dead drive to ressurection! I also tried the same scenario i.e. running testdisk etc but no luck...

A few things to point out is that My Passport is the one with the I/O board on the drive so I can't take it out and plug it directly. Any ideas??!!

Thanking you in advance

Sponsored links

igelkott
Posts: 2
Joined: 21 Aug 2013, 17:03

Re: WD My Passport 1TB Weird issue - Almost dead drive

#2 Post by igelkott » 21 Aug 2013, 18:00

I have the same issue with exactly the same drive. Did you come up with a solution?

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests