OSX exFAT File Corruption [Updated]

Using TestDisk to repair the filesystem
Post Reply
Message
Author
Psyringe
Posts: 3
Joined: 19 Aug 2013, 16:35

OSX exFAT File Corruption [Updated]

#1 Post by Psyringe » 20 Aug 2013, 05:10

Hello. I have something that many users encounter that has little coverage - the dreaded OSX exFAT file corruption issue! It's a unique case, and I'll start as informatively as I can.

Drive Info:
-Seagate Barracuda LP 1.5TB
-The drive is a single exFAT partition.
-Contains no operating system.
OS's:
-OSX 10.6.8 x64
-Windows 7 Service Pack 1 x64

Early this weekend the culprit Hard Drive began showing empty folders, shortly after un-mounting itself. I performed a Repair via Disk Utility (first instinct), it fixed a handful of lines in the red - "Successfully Repaired" - following the Hard Drive Mounts as "Untitled" and empty. No, I do not have a screenshot of the Disk Utility Repair & it's script, I didn't anticipate reaching this forum (although if Disk Utility dumps this info somewhere I can retrieve it). A second Disk Utility repair warranted no fixes, claiming no errors. I pulled the hard drive and moved it to an open SATA port on my PC.

**Please Note: Plugging the Hard Drive via USB to a Windows operating system warrants a "Raw" result, unlike OSX which mounts fine via USB. Plugging in via SATA warrants the same results as OSX (Mounted Empty Drive).**

I run a "chkdsk (drive): /r " - it finds corrupted sectors, finishes the process, drive remains empty. At this point I panic - image the Hard Drive. I run a "chkdsk (drive): /f", finds no errors. I get a copy of R-Studio, begin recovering files, although under interesting conditions - it shows exFAT, HFS, and HFS+ recoverable partitions nearing a dozen varied and overlapping sectors - even crashing the Software when selecting from some of the Partitions "Recognized". Naturally, very few folder structures were recovered, most files are present, but without file names. I'm already %75 complete recovering the files, a fail scenario here merely means no icing on the cake -- and to wade off other similar OSX exFAT Corrupted users straight to Data Recovery to save time.

OK! So here's what I've done with TestDisk:
1. [Create]
2. Select Disk
3. Partition Table Type DEFAULTS [None]
3.1. SELECT [Intel]
4. [Analyse]
5. No Partitions Are Found, [Quick Search]
5.1. [Quick Search] & [Deeper Search] Results
[Intel] - [Quick Search] - [Deeper Search].jpg
[Intel] - [Quick Search] - [Deeper Search].jpg (66.28 KiB) Viewed 4596 times
5.2. Re-Entry to [Quick Search] shows the following:
[Intel] - [Quick Search] 2nd Entry.jpg
[Intel] - [Quick Search] 2nd Entry.jpg (85.32 KiB) Viewed 4596 times
6. [Options]
6.1. Enable Expert Mode
7. [Advanced]
7.1. A Single Partition is Listed
7.2. "1 * SpeedStor 255816 161 14 511633 67 26 4109694196"
7.3. No [Boot] Option Exists
8. [Type]
8.1. [Type] is currently set to [f4]
9. (BACK TO STEP 3) "Select the partition table type"
9.1. Select [None]
10. Select [Advanced]
10.1. Select [Boot]
[None] - [Advanced] - [Boot].jpg
[None] - [Advanced] - [Boot].jpg (49.52 KiB) Viewed 4596 times
10.2. **Please Note Selecting
  • Crashes Software**

    This has been my stopping point before further scouring this forum for situations similar to mine concerning exFAT - none of which to this point are similar at all what-so-ever. I have no idea how to proceed, my conditions seem unique. Please troubleshoot me. I'm open to Ideas and to further providing information that may help repair the Hard Drive, if possible. I anticipated failure from the get-go and already began recovery via other means.

Sponsored links

Psyringe
Posts: 3
Joined: 19 Aug 2013, 16:35

Re: OSX exFAT File Corruption [Updated]

#2 Post by Psyringe » 22 Aug 2013, 09:18

I'd just like to state it took 4 days to get this posting approved & published - which is practically a lifetime in data recovery world. I did put the culprit Hard Drive on hold until now, hoping for at least a reply. CGreiner approved the messages, left no replies. My "garbage" post was also approved - which leads me to believe either A. A Robot scrolled through and pushed "Yes", or B. The moderators hardly care to examine content, lol. After paying a little closer attention - the Filesystem Repair section of this Forum receives little to no attention.

So I'm going to give it a final comment and call this closed -
0. I'm willing to bet corruption of the HFS, HFS+, and exFAT all had to do with the data loss. I could find large traces of HFS and HFS+ partition volumes using a more legit software, R-Studio. Please note - this software found no traces of HFS, or HFS+, putting it's detection methods into the crap bucket.
A. If this software could fix my situation, the proper information for exFAT is not provided on this Forum or on the Website. If you're an exFAT user having similar issues, avoid this software and seek an alternative solution.
B. I was able to recover 99.5% Vital Data using R-Studio, a lot of it including names. From what I can tell there was a corruption - I may have lost some filenames but retained all other info (dates, data recovered was in piles of relevant data, etc). So this software was a last ditch effort to retain the file hierarchies.
C. By the time this post was approved - I have nearly recovered, re-labled, and properly organized over 25,000 Images, 5000 video files, and 75,000 stock 3D files -- this alongside hundred of documents. As previously mentioned, 4 days to approve a thread is a lifetime in data recovery world. A Joke.

Don't bet, or invest time, in this software. If your fix wasn't mentioned, don't expect any support for some open source software that's likely been done 100x better elsewhere that actually has the support it needs to advance and grow.

With that said, now that I've recovered everything regardless by hand, I'm going to format the drive and copy everything back - I left it in it's state to give these bozo's a chance. Epic fail. Thanks anyway. Users beware.

User avatar
cgrenier
Site Admin
Posts: 3464
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: OSX exFAT File Corruption [Updated]

#3 Post by cgrenier » 25 Aug 2013, 10:24

TestDisk 6.14 can
- recover lost/deleted exFAT partition
- recover deleted files from exFAT filesystem
- use the exFAT backup boot sector to repair the main boot sector
but it can't repair corrupted exFAT filesystem.

When "Drive J:" was selected, partition table type defaults to None, it's the correct setting.
By forcing the choice to Intel, the user has forced TestDisk to interpret the boot sector content as Intel partition table entries, it's why bogus partitions are listed.
To search for lost partitions always select a PhysicalDisk, not a drive letter. In this case, the partition table is ok, so it wasn't necessary.

Listed in 10.2, TestDisk crashed when parsing the corrupted exFAT filesystem. Unless you provide some information like the exact error message, stackdump trace..., the problem can't hardly be fixed.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests