Hitachi 3 TB broken partition

How to use TestDisk to recover lost partition
Post Reply
Message
Author
oggy3000
Posts: 1
Joined: 01 Sep 2013, 12:12

Hitachi 3 TB broken partition

#1 Post by oggy3000 » 01 Sep 2013, 20:59

Hi folks,
I have a 3,5" external Hitachi drive with 3TB capacity, formatted in NTFS. It seems that the controller of the disc case is broken because the drive doesn't spin up anymore. Anyway, now I put the drive into my desktop PC in which it spins up and is recognised. Unfortunately Windows first told me to format the drive etc. and now tells me that there are three "parts" on the drive instead of one big one.

Image

I was checking for rescue tools and finally found Testdisk.
I am not familiar with Testdisk and am afraid that I might break something.
However I ran the first analysis on the device which is properly recognized (size etc.)

Image

After that I was confused in the end because in several guides it says "press p" to list files after the analysis but the option is not shown for me. I was also wondering about the FAT16 file system because it should be NTFS.

Image

I pressed it anyway but there are only cryptic signs and it says "no file system found" when you access single entries.

Image

Image

Now I don't really know what to do but hope to be able to restore my files. Please find the log below.

Code: Select all

Sun Sep  1 13:28:19 2013
Command line: TestDisk

TestDisk 6.14, Data Recovery Utility, July 2013
Christophe GRENIER <grenier@cgsecurity.org>
http://www.cgsecurity.org
OS: Windows 7 (7601) SP1
Compiler: GCC 4.7, Cygwin 1007.17
Compilation date: 2013-07-30T14:08:52
ext2fs lib: 1.42.2, ntfs lib: 10:0:0, reiserfs lib: 0.3.1-rc8, ewf lib: 20120504
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sda)=3000592982016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdb)=250059350016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdc)=1000204886016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdd)=2000396746752
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive0)=3000592982016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive1)=250059350016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive2)=1000204886016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive3)=2000396746752
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\C:)=40238055424
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\D:)=104857600000
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\E:)=375072735744
filewin32_getfilesize(\\.\F:) GetFileSize err Unzulässige Funktion.

filewin32_setfilepointer(\\.\F:) SetFilePointer err Unzulässige Funktion.

Warning: can't get size for \\.\F:
filewin32_getfilesize(\\.\G:) GetFileSize err Unzulässige Funktion.

filewin32_setfilepointer(\\.\G:) SetFilePointer err Unzulässige Funktion.

Warning: can't get size for \\.\G:
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\H:)=2000395698176
filewin32_getfilesize(\\.\I:) GetFileSize err Unzulässige Funktion.

filewin32_setfilepointer(\\.\I:) SetFilePointer err Unzulässige Funktion.

Warning: can't get size for \\.\I:
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\J:)=419431432192
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\M:)=356009377792
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\P:)=104856551424
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\S:)=67476914176
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\X:)=157286383616
Hard disk list
Disk /dev/sda - 3000 GB / 2794 GiB - CHS 364801 255 63, sector size=512 - Hitachi HDS723030ALA640, S/N:2020202020204b4d333033334859504759534352, FW:MKAOA5C0
Disk /dev/sdb - 250 GB / 232 GiB - CHS 114754 224 19, sector size=512 - SAMSUNG SP2504C, S/N:30535139314a5930324237303130202020202020, FW:VT100-33
Disk /dev/sdc - 1000 GB / 931 GiB - CHS 953869 64 32, sector size=512 - SAMSUNG HD103SI
Disk /dev/sdd - 2000 GB / 1863 GiB - CHS 243201 255 63, sector size=512 - WD Elements 1048, S/N:WX91E13RAM69, FW:1022

Partition table type (auto): Intel
Disk /dev/sda - 3000 GB / 2794 GiB - Hitachi HDS723030ALA640
Partition table type: Intel

Analyse Disk /dev/sda - 3000 GB / 2794 GiB - CHS 364801 255 63
Geometry from i386 MBR: head=255 sector=63
check_part_i386 failed for partition type 07
get_geometry_from_list_part_aux head=255 nbr=2
get_geometry_from_list_part_aux head=8 nbr=2
get_geometry_from_list_part_aux head=16 nbr=2
get_geometry_from_list_part_aux head=32 nbr=2
get_geometry_from_list_part_aux head=64 nbr=1
get_geometry_from_list_part_aux head=128 nbr=1
get_geometry_from_list_part_aux head=240 nbr=2
get_geometry_from_list_part_aux head=255 nbr=2
Current partition structure:
Invalid NTFS or EXFAT boot
 1 P HPFS - NTFS              0   1  1 45599 254 63  732563937
 1 P HPFS - NTFS              0   1  1 45599 254 63  732563937
No partition is bootable
Best regards :)

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3461
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Hitachi 3 TB broken partition

#2 Post by cgrenier » 06 Sep 2013, 07:30

The partition table is ok, it's the NTFS boot sector that is damaged.
Run TestDisk, Advanced, select the NTFS partition, Boot,
if available, choose BackupBS, confirm, Quit
otherwise, choose RebuildBS, List, Write and confirm if you can see your files.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 1 guest