TestDisk is lying to me! Topic is solved

Using TestDisk to repair the filesystem
Locked
Message
Author
Bmob
Posts: 2
Joined: 02 Sep 2013, 16:45

TestDisk is lying to me!

#1 Post by Bmob » 02 Sep 2013, 18:20

Hello,

my Problem is likely not a new one: When I started my PC (Win7) yesterday, the filesystem on my large NTFS data-partition had turned into RAW. I'm not that well versed in partitioning-magic (joke) myself, but I found a lot of people who had seemlingly the same problem, so I followed the same instructions to restore the filesystem with TestDisk.

However, after rebooting, my system remains unchanged and the partition is still shown as unformated! Even repeating the process two more times had no noticable effect. I must be doinf it wrong, then.

I have two drives, C: and D:, both are partitions on a Raid0 made from two 1TB hard-drives.
C: and D: are roughly 200GB and 1,6TB in size

The current state pf my System, as seen from the windows file-browser, is as follows:
C: windows- and boot- partition (unaffected, works as intended as far as I noticed)
D: unformated
+ CD-drive

The windows device-manager tells me that on device 0 there are 3 partitions:
system-reserved 100MB
C: NTFS 198GB (boot, primary)
D: RAW 1666GB (Primary)

Now so far thats exactly the same Problem I had from the start. What I don't understand is whatever TestDisk is trying to tell me. When I start the program it shows me two devices:
- Disk /dev/sda - 2000GB / 1863GiB - Intel Raid 0 Volume
- CD-drive

When I choose the Raid > type [Intel] (as preselected) > [Advanced], it shows me this:

1 * HPFS - NTFS Start 0 32 33 End 12 223 19 Size 204800 [system-reserved]
2 P HPFS - NTFS Start 12 223 20 End 25687 164 13 Size 412465152
3 P HPFS - NTFS Start 25687 164 14 End 243201 175 46 Size 3494363136 [data]

which is completely fine as far as I can tell! Even if I look at my files of partition 3 with
  • , the filestructure looks intact.

    If I go back and choose [Analyse] > [Quick Search] the same comes up and if I continue and [Write], it seems to work with no problems. But even after I restart the PC the problem remains unchanged.

    As far as I understand it the partitions look perfectly fine in TestDisk but in windows the large partition (D:) is still RAW.

    Could anyone here with more experience than me tell me what I am doing wrong? I would be very grateful for any hints or pointers.


    Yours,
    Bmob

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3403
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: TestDisk is lying to me!

#2 Post by cgrenier » 06 Sep 2013, 07:58

Run "chkdsk /f c:" (or D:...)

Bmob
Posts: 2
Joined: 02 Sep 2013, 16:45

Re: TestDisk is lying to me!  Topic is solved

#3 Post by Bmob » 06 Sep 2013, 10:42

Thank you very much, but the problem solved itself.
I had TestDisk rebuild the bootsector - which caused a bluescreen, probably because my operating system is on that harddrive - and after a restart all partitions are now working again as intended. No data has been lost or damaged fortunately.
I think I had tried that before but I had probably forgotten to run it with admin-rights.
Well, I'm still not sure why TestDisk did not show me any errors when something was clearly wrong, even the bootsector section did not hint at any problems - which caused me some confusion.

But in the end the problem was solved, my partitions are restored and my data is save for now. SO, I'm really grateful for this tool. Loosing more than a Terabyte of stuff would have been very painful even if it's not essential.

Thank you!

Locked

Who is online

Users browsing this forum: No registered users and 0 guests