How should I proceed?

How to use TestDisk to recover lost partition
Post Reply
Message
Author
niconymous
Posts: 2
Joined: 03 Oct 2013, 22:34

How should I proceed?

#1 Post by niconymous » 03 Oct 2013, 22:47

Hello everyone,

Really hoping you can help me out here, it seems that this forum is the best place to recover a seemingly dead hard drive.

A quick description of the situation: my brother had a WD MyBook Studio 2TB which was attached to his MacBook Pro (HFS+ etc.). Long story short, it looks like the hard drive broke because of overvoltage (he lives in a country where the electrical system is pretty dodgy). The circuit in the hard drive case has died, but the hard drive itself turns on when it's connected to another case or internally.

I connected it to a Windows machine to run TestDisk on, but I made the mistake of clicking "initialise" thinking that it wouldn't actually write anything to disk.

I ran TestDisk ("Deep Search"), it took 3 days, but finally got stuck at 93%, after having found the following partitions:

Image

Now, I don't really know how to interpret the results, or what to do. According to the internet (and considering this is a GPT/HFS+ hard drive), I should connect it to a Mac, and use the information from TestDisk in pdisk to rewrite the partition table.

Could you tell me how you think I should proceed with the information I've provided?

Thanks in advance,

Nicolas
Last edited by niconymous on 07 Oct 2013, 12:22, edited 2 times in total.

Sponsored links

niconymous
Posts: 2
Joined: 03 Oct 2013, 22:34

Re: How should I proceed?

#2 Post by niconymous » 05 Oct 2013, 14:21

Hi,

Thanks for accepting the post. I have a few updates to make to my original message.
The "Deeper Search" finally managed to completely after staying stuck on 227230 for about 12 hours, here are the screenshots:
Image
Image

I'm guessing that the MS Data partition is due to my earlier initialisation using Windows. As for the Mac HFS partition, I don't know what to think. I know there was only one partition on the disk, but the size in sectors looks pretty small.

I also read on this forum and elsewhere that these disks are usually hardware-encrypted and have a unique encryption key in the SATA-to-USB bridge. The problem is that the original bridge is the part that's dead...

Could you let me know what you think, or if any solutions come to mind?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest