did testdisk kill my drive?

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 07 Apr 2012, 20:17

did testdisk kill my drive?

#1 Post by ctbram »

I had an external esata disk that was showing up as RAW and must be formatted to use.

I ran testdisk, analyzed, it saw the disk and found 1 partition, I selected and chose [write]. It very quickly responded you must reboot for changes to take affect. I rebooted and the system sat there with rebooting.... for over 4 hours! Seriously, I went to launch, then walked the dog, then watched a movie....

I reset the system because it was obviously hung. The machine rebooted and when I tried to turn on the esata enclosure it saw no disk at all! I went to disk management and rescanned the drives and could not see the drive.

I shut down the system, removed an internal drive and replaced it with the now DEAD drive and the system hangs in bios when it gets to the point where it scans the disks!!!! I let it sit for a couple minutes and it displays all the disks but the now dead one which shows as sata 1 none.

I disconnected all the disks but that one and reboot. The system hangs when it reaches the drive scan and after a long 3 to 4 minutes it shows no drives attached to the system!

So now I cannot even see the drive! I stalls the system at boot when it gets queried. So what the hell did writing to the partition to the disk do to kill my disk and is there any way to recover at this point!

I really hate windows 7. I had been running vista for years and never once corrupted an external disk! This the the third one I have put in my external enclosure since upgrading to win7 now that has been converted to RAW. I had an app that recovered the files but not the partition tables and so I'd end up with one folder with every file on my 500GB disk and have to spend tons of time trying to sort everything back out. It's not like I just pull it out either. If I cannot unmount it I shut the machine down and that remove it. This particular one, said installing new hardware when i turned the enclosure on and then reboot for changes to take affect. I rebooted and the disk was corrupted and showed up as RAW! I am so pissed at this point I could take a hammer to the damn thing. I had three years worth of unrecoverable 3D models I had built. I had no clue that I could wreck the drive so badly with testdrive that now I cannot even see it!

I used this testdisk prgram in the hopes of repairing the partition table and now have apparently completely killed the disk and lost all my data?

I am particularly pissed because I have a multiport controller that died and I have been saving to replace but everytime I get a couple bucks I have to send it to seagate to replace dead drives!

Is there any hope at all? I suspect I am boned as I have no idea how to repair a drive that no longer even reports!
User avatar
Posts: 456
Joined: 25 Mar 2012, 10:21
Location: Strasbourg, France.

Re: did testdisk kill my drive?

#2 Post by remy »

Testdisk can't kill your disk. Testdisk has done exactely what you have asked to : rewrite a good partition table, that is to say rewrite the first sector of the disk, and only it.

You tell you have already 3 disk going to RAW. Perhaps the problème is elsewhere than with testdisk.

What's the model of your disk ? Seagate : 7200.11 / 7200.12 ?