A few "Warning: number of heads/cylinder mismatches" Topic is solved

Using TestDisk to undelete files
Locked
Message
Author
Winfried
Posts: 2
Joined: 28 Oct 2013, 23:08

A few "Warning: number of heads/cylinder mismatches"

#1 Post by Winfried » 28 Oct 2013, 23:17

Hello

I'm helping a friend recover files she deleted by mistake on her Windows8 laptop.

This is the first time I'm using TestDisk, and the first time I'm working with a Windows8 host with a UEFI BIOS and GPT partitions. FWIW, this is TestDisk 6.14-WIP on a USB keydrive burned with Knoppix 7.2.0.

I'll let Testdisk run through the night to analyse the 750GB NTFS partition, but in the mean time, I have a couple of newbie questions to which I found no answer on the site:

1. Why does "parted /dev/sda print" display multiple partitions instead of just one?

Code: Select all

# fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sda: 750.2 GB, 750156374016 bytes
256 heads, 63 sectors/track, 90845 cylinders, total 1465149168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x61afbb41

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1  4294967295  2147483647+  ee  GPT
Partition 1 does not start on physical sector boundary.

# parted /dev/sda print
Model: ATA ST750LM022 HN-M7 (scsi)
Disk /dev/sda: 750GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  316MB   315MB   fat32        EFI system partition          boot
 2      316MB   1259MB  944MB   ntfs         Basic data partition          hidden, diag
 3      1259MB  1394MB  134MB                Microsoft reserved partition  msftres
 4      1394MB  301GB   300GB   ntfs         Basic data partition
 5      301GB   729GB   427GB   ntfs         Basic data partition
 6      729GB   750GB   21,5GB  ntfs         Basic data partition          hidden, diag
2. Why does TestDisk display the following messages several times while running a deep search?

Code: Select all

...
Warning: number of heads/cylinder mismatches 16 (NTFS) != 255 (HD)
Warning: number of sectors per track mismatches 2 (NTFS) != 63 (HD)
...
Thank you.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3683
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: A few "Warning: number of heads/cylinder mismatches"  Topic is solved

#2 Post by cgrenier » 30 Oct 2013, 08:26

When a EFI GPT partition table is present, a PC/Intel partition table is also created with a single partition that use the whole disk to prevent old disk utility to see the disk as empty.

The warning about the disk are only warnings, not errors. They indicate sthat the disk geometry is different than the geometry information stored in FAT or NTFS boot sector.

Winfried
Posts: 2
Joined: 28 Oct 2013, 23:08

Re: A few "Warning: number of heads/cylinder mismatches"

#3 Post by Winfried » 30 Oct 2013, 14:47

Thanks for the info.

Testdisk was able to recover most of the files my friend deleted by mistake. All it took is going into the Advanced section, hitting "a" to select all the files, and copy them to an external drive. Thumbs up!

Locked

Who is online

Users browsing this forum: No registered users and 0 guests