Video files recovered but won't play

Using TestDisk to undelete files
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Message
Author
evansmith
Posts: 1
Joined: 10 Nov 2013, 17:10

Video files recovered but won't play

#1 Post by evansmith » 10 Nov 2013, 17:15

I have used Photorec to recover some .mp4 files off of an SD card. It recovered 35 files (I'm only hoping to recover 6 specific deleted files), but they were all unable to play. Interestingly, some of the files were .mov files, which my camera does not create. Based on recommendations online I tried using the camera as a hard drive instead of plugging the card into the computer and got similar results.

Is there a trick I don't know?

The recovered files appear like this:
f0008448.mp4
f0008896.mp4
f0890336.mov
f0891072.mp4
f0891394.mp4
f0891520.mp4
f1067360.mov
f1067520.mp4
f1180352.mp4
f1296704.mp4
f1488960.mp4
f1811616.mov
f1907808.mov
f2211936.mov
f2212160.apple
f2331072.gz
f2962304.mp4
f3030080.apple
f3090784.mov
f3263200.mov
f3527168.mp4
f3992224.mov
f4108416.mp4
f4517920.mov
f4518272.mp4
f4530272.mov
f4530496.mp4
f5445088.mov
f5445120.mp4
f5861408.mov
f5861632.mp4
f6018656.mov
f6018752.mp4
f6196064.mov
f6196288.mp4
f6734432.mov
report.xml

Sponsored links

Bob88
Posts: 1
Joined: 12 Dec 2013, 20:05

Re: Video files recovered but won't play

#2 Post by Bob88 » 12 Dec 2013, 20:40

I have had the same issue as evansmith. I recovered some .mp4 files from an SD card using PhotoRec, but they won't play so I'm not sure if I have recovered the ones that were accidently deleted. When I try to play the files, it appears to be playing but with no audio and no video. Any suggestions?

WhiteHotLoveTiger
Posts: 1
Joined: 26 Dec 2013, 18:26

Re: Video files recovered but won't play

#3 Post by WhiteHotLoveTiger » 26 Dec 2013, 18:32

Like Evan and Bob, I also have this problem. I tried PhotoRec to recover the filess, as well as TestDisk's undelete utility. These created different sets of files. The PhotoRec ones were completely unplayable, however the undeleted ones will play static audio and a few of them will display the first frame of video.

Any suggestions for better recovery or for repairing the recovered files?

User avatar
cgrenier
Site Admin
Posts: 4246
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Video files recovered but won't play

#4 Post by cgrenier » 04 Jan 2014, 10:08

Some camera like GoPro or JVC produce fragmented video files.

Sort the recovered files by filename. If you get for each original video two files (mov or mp4), it's usually possible to fix the video.
In command line (Windows), go in the directory where the files are "cd directoryname" and
run "type small.mov big.mov > video.mov"
For Linux or Mac OS X, start a Terminal and use "cat" instead of "type".

yetisam
Posts: 5
Joined: 20 Feb 2014, 09:47

Re: Video files recovered but won't play

#5 Post by yetisam » 20 Feb 2014, 15:23

cgrenier wrote:Some camera like GoPro or JVC produce fragmented video files.

Sort the recovered files by filename. If you get for each original video two files (mov or mp4), it's usually possible to fix the video.
In command line (Windows), go in the directory where the files are "cd directoryname" and
run "type small.mov big.mov > video.mov"
For Linux or Mac OS X, start a Terminal and use "cat" instead of "type".
i tyed to do like cgrenier suggest but the video resuledt from type command is unplayable too.

i got a gorpo and the file seems to be recovered.
Go pro has a file in low resolution, a file with resolution as recorded 720x50 fps and a thumbnail .jpg.

Hardway108
Posts: 3
Joined: 29 Dec 2017, 07:18

Re: Video files recovered but won't play

#6 Post by Hardway108 » 29 Dec 2017, 07:34

Same problem here. Video files recordedon Canon 80D. I was able to pull files using photo rec and test disk but none of the files can play.

form test disk I pulled some 60 files
Mode LastWriteTime Length Name
---- ------------- ------ ----
-a---- 12/6/2017 7:34 PM 5181014 _VI_1253.MP4
-a---- 12/6/2017 7:35 PM 99493910 _VI_1254.DAT
-a---- 12/6/2017 7:34 PM 99592214 _VI_1254.MP4
-a---- 12/6/2017 7:36 PM 270730786 _VI_1255.DAT
-a---- 12/6/2017 7:35 PM 270861858 _VI_1255.MP4
-a---- 12/6/2017 7:39 PM 513252076 _VI_1256.DAT
-a---- 12/6/2017 7:37 PM 513415916 _VI_1256.MP4
-a---- 12/6/2017 7:41 PM 326012180 _VI_1257.DAT
-a---- 12/6/2017 7:40 PM 326143252 _VI_1257.MP4
-a---- 12/6/2017 7:48 PM 59097996 _VI_1258.DAT
-a---- 12/6/2017 7:48 PM 59196300 _VI_1258.MP4
-a---- 12/6/2017 7:49 PM 148353778 _VI_1259.DAT
-a---- 12/6/2017 7:49 PM 148452082 _VI_1259.MP4
-a---- 12/6/2017 7:55 PM 1163303907 _VI_1260.DAT
-a---- 12/6/2017 7:50 PM 1163566051 _VI_1260.MP4
-a---- 12/9/2017 8:56 AM 2911002313 _VI_1261.DAT
-a---- 12/9/2017 8:43 AM 2911493833 _VI_1261.MP4
-a---- 12/9/2017 9:11 AM 687046742 _VI_1262.DAT
-a---- 12/9/2017 9:08 AM 687243350 _VI_1262.MP4
-a---- 12/9/2017 9:21 AM 2214793193 _VI_1263.DAT
-a---- 12/9/2017 9:11 AM 2215186409 _VI_1263.MP4
-a---- 12/9/2017 9:35 AM 1050719944 _VI_1264.DAT
-a---- 12/9/2017 9:30 AM 1050949320 _VI_1264.MP4
-a---- 12/9/2017 9:54 AM 4213155149 _VI_1265.DAT
-a---- 12/9/2017 9:35 AM 4213876045 _VI_1265.MP4
-a---- 12/9/2017 9:56 AM 254235288 _VI_1266.DAT
-a---- 12/9/2017 9:54 AM 254366360 _VI_1266.MP4
-a---- 12/9/2017 9:56 AM 4634029 _VI_1267.DAT
-a---- 12/9/2017 9:56 AM 4732333 _VI_1267.MP4
-a---- 12/9/2017 10:11 AM 3278848724 _VI_1268.DAT
-a---- 12/9/2017 9:56 AM 3279438548 _VI_1268.MP4
-a---- 12/9/2017 10:17 AM 1279268988 _VI_1269.DAT
-a---- 12/9/2017 10:12 AM 1279531132 _VI_1269.MP4
-a---- 12/9/2017 10:56 AM 3843865677 _VI_1270.DAT
-a---- 12/9/2017 10:39 AM 3844521037 _VI_1270.MP4
-a---- 12/9/2017 11:30 AM 3710558260 _VI_1271.DAT
-a---- 12/9/2017 11:14 AM 3711180852 _VI_1271.MP4
-a---- 12/9/2017 11:48 AM 3533519715 _VI_1272.DAT
-a---- 12/9/2017 11:33 AM 3534109539 _VI_1272.MP4
-a---- 12/20/2017 1:02 PM 67775410 _VI_1312.DAT
-a---- 12/20/2017 1:02 PM 67873714 _VI_1312.MP4
-a---- 12/20/2017 1:03 PM 22701052 _VI_1313.DAT
-a---- 12/20/2017 1:03 PM 22799356 _VI_1313.MP4
-a---- 12/20/2017 1:03 PM 21346976 _VI_1314.DAT
-a---- 12/20/2017 1:03 PM 21445280 _VI_1314.MP4
-a---- 12/20/2017 1:46 PM 3289215801 _VI_1315.DAT
-a---- 12/20/2017 1:30 PM 3289805625 _VI_1315.MP4
-a---- 12/20/2017 2:09 PM 4211840150 _VI_1316.DAT
-a---- 12/20/2017 1:49 PM 4212561046 _VI_1316.MP4
-a---- 12/20/2017 2:12 PM 722414899 _VI_1317.DAT
-a---- 12/20/2017 2:09 PM 722611507 _VI_1317.MP4
-a---- 12/20/2017 2:23 PM 1326712189 _VI_1318.DAT
-a---- 12/20/2017 2:17 PM 1326974333 _VI_1318.MP4
-a---- 12/22/2017 11:38 AM 3886999452 _VI_1319.DAT
-a---- 12/22/2017 11:21 AM 3887654812 _VI_1319.MP4
-a---- 12/22/2017 12:09 PM 2172567968 _VI_1320.DAT
-a---- 12/22/2017 11:59 AM 2172961184 _VI_1320.MP4
-a---- 12/22/2017 12:23 PM 1976840119 _VI_1321.DAT
-a---- 12/22/2017 12:14 PM 1977233335 _VI_1321.MP4
-a---- 12/26/2017 12:10 PM 2891435481 _VI_1322.DAT
-a---- 12/26/2017 11:54 AM 2892058073 _VI_1322.MP4
-a---- 12/26/2017 12:36 PM 1194514157 _VI_1323.DAT
-a---- 12/26/2017 12:29 PM 1194841837 _VI_1323.MP4

None of them are readable like the other guys here. What is the next step? or am I out of luck?

User avatar
cgrenier
Site Admin
Posts: 4246
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Video files recovered but won't play

#7 Post by cgrenier » 29 Dec 2017, 18:54

Have you try to use PhotoRec as explained in https://www.cgsecurity.org/testdisk.pdf chapter "Recovering lost videos from a memory card using PhotoRec" ?

Hardway108
Posts: 3
Joined: 29 Dec 2017, 07:18

Re: Video files recovered but won't play

#8 Post by Hardway108 » 01 Jan 2018, 22:24

Yes I tried the string type _VI_1323.mp4 _VI_1323.dat > Test.mp4

this opens windows media player automatically and plays a 7 minute black screen with no sound. the resultant file test.mp4 does not show any of the video or audio but plays a 7 minute silent black video.

I reversed the order of files with the same result dat before mp4.

User avatar
cgrenier
Site Admin
Posts: 4246
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Video files recovered but won't play

#9 Post by cgrenier » 05 Jan 2018, 09:45

You need to try using the files recovered by PhotoRec as explained in the pdf, not the files recovered via testdisk.

Hardway108
Posts: 3
Joined: 29 Dec 2017, 07:18

Re: Video files recovered but won't play

#10 Post by Hardway108 » 06 Jan 2018, 06:37

the files from photo Rex did not match up by name the way the PDF stated.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest