HFS+ reading as Fat and was not formatted fat.

How to use TestDisk to recover lost partition
Post Reply
Message
Author
nkolvek
Posts: 1
Joined: 21 Nov 2013, 19:57

HFS+ reading as Fat and was not formatted fat.

#1 Post by nkolvek » 21 Nov 2013, 20:05

Here is my problem. I have a small 60gb external that was formatted HFS+ and contained some important files for a recording studio. I had loaded the windows bootcamp HFS+ read/write driver and after rebooting the machine and plugging in the drive, it now shows it is a FAT drive and not HFS+. I have run stellar on the drive for recovery but stellar has pulled Pro Tools .PTS files off as a unix file which is a problem. I am trying to use TestDisk to change the partition back to HFS+ but I am so confused with this software it's not funny.

I am hoping that I can do this without loosing any of the data on the drive but now testdisk is telling me I have to use pdisk and pdisk just doesn't want to cooperate and doesnt even show the drive. When OSX tries to mount the disk I just get an error and it wants to either initialize the disk, ignore and eject it.

Testdisk correctly scans the drive and shows it is a HFS+ partition but I have tried to look through the help files which basically only tell you how to work with NTFS only.

I would really like to fix this drive without loosing the data on it. I have already made several backups of the drive incase of a problem. So far I have used stellar to recover the contents, made a dmg file of the drive itself and now would like to work with the actual drive but I'm just totally lost with the lack of tutorials. Is there anyone that can help me?

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3419
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: HFS+ reading as Fat and was not formatted fat.

#2 Post by cgrenier » 21 Nov 2013, 22:49

The disk was probably using an EFI GPT or PC Intel partition ttable, not an old Mac partition table.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests