Recupération de partition : Deeper Search : pas de status ?

Comment utiliser TestDisk pour récupérer une partition perdue
Post Reply
Message
Author
Pierrick
Posts: 1
Joined: 05 Dec 2013, 09:56

Recupération de partition : Deeper Search : pas de status ?

#1 Post by Pierrick » 05 Dec 2013, 10:05

Bonjour,

J'ai lancé, suite à un problème sur un serveur, et après différentes opérations ayant permis d'accéder aux disques (2 disques de 1Tio chacun, en RAID1) et découvert qu'il manquait la partition de données, une analyse testdisk.

J'ai utilisé la version 32bits sur le serveur sous windows server 2012 (64bits).

L'étape "Deeper Search" me permet de voir la partition qui m'intéresse, mais je n'ai pas les indications de status (*, P, L, E, D; je n'ai aucune indication à ce niveau). Est-ce normal ?

De plus, j'ai eut un message indiquant que mes disques étaient trop petit. Est-ce lié au RAID1 qui ferait remonté deux fois plus de surface que la taille du disque virtuel ?


Je n'ai pas le log, n'ayant pas voulu prendre le risque d'écraser plus mes données.
Je vais relancer la manipulation depuis le début afin de pouvoir le fournir à la suite de ce sujet et avant de faire une manipulation potentiellement désastreuse.

[Edit]
Problème "résolu" dans ses grandes ligne, mais il me reste une question (voir à la fin)

Petit recap depuis hier :
il semblerait que sur le serveur, l'affichage des D soit implicite.
En comparant les informations, j'ai réussi à voir quelles étaient mes deux partitions, et j'ai put les restaurée (une en * l'autre en P)
Le serveur une fois redémarré affichait bien ma partition contenant l'OS à la taille voulue, mais la deuxieme partition était invisible.

J'ai ensuite utiliser des commandes DISKPART pour voir l'état :
- la partition était en l'état "masquée"
- le disque n'était pas indiqué comme dynamique
- il manquait le volume associé à la partition
=> modification du disque en dynamique, création du volume manquant.

Malheureusement, cette opération n'a pas résolu le problème, la commande ASSIGN renvoyant à chaque fois une erreur système.

J'ai ensuite tenté de déplacer le disque sur une autre machine (un seul des deux disque de la grappe raid) => vision d'une seule partition occupant toute la surface du disque.

Retour dans le serveur : impossible de démarrer.
Réinstallation de windows serveur sur le 3e disque
- la machine démarre et donne accès aux différentes partitions et volumes, sauf celle qui m'intéresse bien que visible.
- Diskpart pour une commande ASSIGN (l'interface graphique refusant l'opération) : Réussite.

Ensuite, sauvegarde des données sur disque externe pour utilisation sur un poste individuel.
Les machines virtuelles (les données qui étaient les plus importantes dans cette tentative de récupération) sont automatiquement détectée par le windows8 du poste, récupération du contenu en cours.

QUESTION :
Il m'est cependant impossible de redémarrer le serveur sur l'instance windows originale installée sur une des deux partitions récupérées avec Testdisk. Il lance systématiquement l'instance installée sur le 3e disque de la machine.
Quelle manipulation pourrait-je avoir à faire pour la rendre à nouveau disponible ?

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3813
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Recupération de partition : Deeper Search : pas de statu

#2 Post by cgrenier » 06 Dec 2013, 19:06

Il faudrait vérifier l'ordre de boot des disques au niveau du BIOS et aussi le fichier boot.ini (fichier système caché par défaut).

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests