CF Card cannot be mounted

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
jcnetwork
Posts: 1
Joined: 18 Dec 2013, 09:33

CF Card cannot be mounted

#1 Post by jcnetwork » 18 Dec 2013, 09:56

I have a SanDisk Extreme 8GB CF Card. The card went bad. It cannot be formatted in camera and when I plug it into the comptuter via a card reader, it doesn't even mount

From another site, i read that if the controller is bad, then no software can help it. But then I found out about cgsecurity. So I downloaded testdisk and photorec. Using a Intel Mac on OS 10.7.5, i tried both TestDisk and PhotoRec but both programs do not see the CF card. It only sees my hard drive.

Please advise what I should do next.

Thank you.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4229
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: CF Card cannot be mounted

#2 Post by cgrenier » 04 Jan 2014, 10:28

I confirm the controller is probably damaged. You need to contact a data recovery company if you have data to recover.
Otherwise use the warranty if applicable to get a card.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest