Problems with SD-Card

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 1
Joined: 12 Jan 2014, 21:47

Problems with SD-Card

#1 Post by mrklee »

I'm having problems restoring a SD card. When starting TestDisk, it get's recognized as an Intel and this:

Trying to analyze it, I'm getting this:

Deeper search brings this:

The boot sector screen in advanced looks like this:

This is what happens, when I try to rebuild the BS:

When I try to restore the photos on it using PhotoRec, it quickly finds 8 jpgs and after that there's a couple of minutes of nothing happening. There should be at least 200 photos on that SD card. Any chance of getting them back? I tried a couple of other recovery tools (Restorer Ultimate, recuva, Recover my Files, Card Recovery) but no luck. Some of them find 25 files but none comes close to the actual number of images.

I would really appreciate if anybody could point me in the right direction. Thank you very much in advance!