quick search very slow with errors

How to use TestDisk to recover lost partition
Post Reply
Message
Author
hardya
Posts: 3
Joined: 18 Feb 2014, 18:39

quick search very slow with errors

#1 Post by hardya » 18 Feb 2014, 18:55

I have a HDD which responds in windows saying it needs formatting

I ran partedmagic from a boot cd but could not manage to mount the drive

I started testdisk and ran quick search but it is very very slow like at cuirrent speed may take > 100 hours to complete.

Also EVERY change of n to the display it shows

Analyse cylinder n/476939 xx%
Read error at n/1/1 (lba=<some large number>)

It is currently up to 12750 aprox and 02% after around 3 hours
I am trying to establish whether what is being displayed and the current progress
tells us 'anything' about the liklihood of success?

Sponsored links

arifali
Posts: 1
Joined: 26 Feb 2014, 14:28

Re: quick search very slow with errors

#2 Post by arifali » 26 Feb 2014, 14:42

Its extremely slow for me, Looks like it will go on for weeks and I need to ensure that power doesn't go off.
Is there any way to speedup the process?

reduce the number of retries on I/O failure

hardya
Posts: 3
Joined: 18 Feb 2014, 18:39

Re: quick search very slow with errors

#3 Post by hardya » 03 Mar 2014, 09:18

I resolved the speed issue. Stupidly I had the drive in a USB enclosure. When accessed directly it was a lot faster.

What I'd be interested in now is a precise meaning of the
. Read error at n/1/1 (lba=<some large number>)
Could it mean there were physical read errors or CRC errors but that it so read after retries? Could it mean it gave up after all retries? Does 1/1 mean platter 1 sector 1, why is it always 1/1 ?

I'm not sure there are many people on this forum actually.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests