Raid 5 recovery Q

How to use TestDisk to recover lost partition
Post Reply
Message
Author
eobiont
Posts: 2
Joined: 10 May 2014, 01:08

Raid 5 recovery Q

#1 Post by eobiont » 10 May 2014, 01:17

Hi everybody. Thanks in advance for helping me.

I have a 3 drive Raid 5 array that got destroyed by a BIOS update. Same old story - two drives dropped from the array. I have not been able to get TestDisk to see files. It says the disk is too small and so it will not recover. I downloaded reclaime to see what I could find there. It does find the RAID information and showed me a directory of the files that looks good, but they'd like $80 ransom to help me restore my files.
Anyway - this is the output of reclaime
<RAID5 blocksize="64" layout="async" parity="2" rotation="2" delay="1" firstdelay="1">
<disk path="\\.\PhysicalDrive3" offset="0" numsectors="5860533168" serial="WMC1T1492679" />
<disk path="\\.\PhysicalDrive4" offset="0" numsectors="5860533168" serial="WMC1T1740507" />
<disk path="\\.\PhysicalDrive5" offset="0" numsectors="5860533168" serial="0301YHKHVETA" />
</RAID5>

so I shutdown the computer and plugged in the drives in the order stated above. I tried to recreate the raid, but testdisk is having a little trouble. First, where it says block size = 64, that means the stripe is 32K? or 64K or 128K?
when building the raid? TestDisk detects the GPT partition, but it says my disk is too small and I can't list files.
Is this enough information for anyone to offer me help? Thanks.

Sponsored links

eobiont
Posts: 2
Joined: 10 May 2014, 01:08

Re: Raid 5 recovery Q

#2 Post by eobiont » 13 May 2014, 00:47

I saw another post in this forum about a user with the same problem - with TestDisk saying the drive appears to be too small. That user increased the number of cylinders by a few and reported this allowed files to be copied off the RAID to a new disk. I decided to try this with my own situation. It worked.

I just took the number of cylinders, which in my case were 729597 and changed the number to 729608 in the geometry menu. This allowed the software to see the file system and move files to another drive.

I did not try to write this new partition back to the drive, because I didn't know what long-term affect there might be with faking out the Number of cylinders - I was just happy to have my data back.

Thanks for your software.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest