Raid10 Recovery problem

How to use TestDisk to recover lost partition
Post Reply
Message
Author
w00t
Posts: 1
Joined: 03 Jun 2014, 06:01

Raid10 Recovery problem

#1 Post by w00t » 03 Jun 2014, 06:51

Looking for advice from the experts out there...

I just had a failure on a 4x3TB RAID10 due to a BIOS reset. Similar to other stories, I had to manually change the BIOS setting back to RAID, then two discs appeared as non-member. I re-created the RAID with the same settings, and as my OS is on a dedicated SSD, I ran Testdisk in Windows 8.

After 3 days of quick scanning (is this normal?) here are the results:
msdata.jpg
msdata.jpg (168.33 KiB) Viewed 826 times
Looking at the last (large) partition, I saw all of my data / directories, everything looked intact, so I set this partition to primary, write / confirm. Then into the boot menu, and both boot sectors were bad. I selected Rebuild, then quit, reboot

The volume appeared in Windows after rebooting, but the first thing I noticed was that it only appeared as ~2TB and my directory structure was there, but none of my files were opening... everything seemed to be corrupt! I went into disk management and noticed a huge "unallocated" partition of over 2TB, and another smaller partition at the beginning, of unallocated space.

After realizing I probably made a huge mistake by restoring this partition and writing a new BS, I am running Testdisk again this time in deep scan. Here is what I see so far:
IMG_20140603_001523.jpg
IMG_20140603_001523.jpg (130.68 KiB) Viewed 826 times
My question...am I wasting my time at this point? Is my volume gone? Also, what is the mismatch error? Did I stripe the volume incorrectly when I rebuilt it? I forget what it originally was but I thought I kept it at the suggested value which is 64KB.

I am thankful that I got to at least see the directory structure and what I had on the volume, so that I know what I lost, but if there's any chance of saving the volume and rebuilding the partition properly, please let me know what I should do!

thanks

Sponsored links

User avatar
Fiona
Posts: 2836
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: Raid10 Recovery problem

#2 Post by Fiona » 04 Jun 2014, 10:58

Please upload another screen from your currrent GPT-partition table ( Analyse / current partition structure).
At least I'd get your current partition structure to decide, either a boot sector repair or a full scan using Quick- or Deeper Search may help?

Fiona

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests