Storage RAID recovery

How to use TestDisk to recover lost partition
Post Reply
Message
Author
Afeagle21
Posts: 1
Joined: 14 Jun 2014, 16:13

Storage RAID recovery

#1 Post by Afeagle21 » 15 Jun 2014, 00:25

My home system originally had an 80GB drive (/dev/sdf) with my Ubuntu load and 2-1TB drives (/dev/sdc & sdd) in RAID 1 for storage purposes. I later added the 500GB (/dev/sde) for an Ubuntu/Windows dual boot and formatted the 80GB drive. I added 2-2TB drives (/dev/sda & sdb) for an additional RAID config but forgot to backup the data from the original 1TB RAID storage. Now when I boot into Ubuntu it cannot mount the 2-1TB RAID array even though it shows as a md RAID setup due to not recognizing the structure type. I cannot remember if I ever actually setup a type for it and cannot access the data. A lot of data is on here and I am trying to use TestDisk to either be able to repair it to be able to mount the RAID again or at least recover the data from the disks. I have attempted to access and copy the files from one (sdc) of the drives, but have only been partially successful and a lot of the folders show as inaccessible. I have floundered around with the program for months now and am looking for any possible assistance on where to go from here. I started TestDisk and selected the log file option. It then listed all of my devices including the 2-1TB drives separately as sdc and sdd as well as them together as /dev/smd127.
Image
This seemed odd that it labeled the RAID array as md127 as later TestDisk identified it as md0. I then chose the Intel option for the partition table type as selecting "none" in the past didn't allow me to copy any files. After selecting the Intel option I chose to Analyze the partition structure and it came back with the following...
Image
From what I can tell, this is the partition I am looking for and it appears the size is the full 1TB drive. So I then selected the quick search and selected the Yes option for searching for partitions created under Vista or later and got the following back after it finished the Quick Search...
Image
I am not sure why it is listing what I assume is the same partition twice and with two different names, "storage" and "md0". Storage is what I had it named when I originally created it and again not sure why it is showing as md0 here and was listed as md127 above. I tried to use the list files option and copy what I could, but a lot of files are not showing as accessible and I am not sure if I am just missing them somewhere else. Again, any help is really appreciated.

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests