Software RAID1 Collapse

How to use TestDisk to recover lost partition
Post Reply
Message
Author
torentigris
Posts: 1
Joined: 27 Jun 2014, 04:50

Software RAID1 Collapse

#1 Post by torentigris » 27 Jun 2014, 05:25

I recently got a new video card from a different manufacturer and... long story short I decided to format and reinstall my Windows 7 Ultimate Install to make things go smoothly. Everything went well, I went through the routine of installing various drivers and programs. Unexpectedly my "Archive" RAID1 array stopped working (where I keep all my important files, thus the mirror). Windows listed both as invalid and I tried to restore them and got an error.
DiskManagement.jpg
Error
DiskManagement.jpg (45.13 KiB) Viewed 538 times
Quick Details:
2 x 3TB Internal Toshiba HDD
Software RAID1-Mirror (Via Windows 7)

FYI: I have successfully used testdisk to copy the files off of a single failing drive (bad-sector explosion) before, but never did any repairs.

I ran testdisk and it was only detecting the drives as 746GB. I looked in the forum and determined that I needed the Intel drivers to allow the 3TB drives to function (my mistake hopefully not a permanent one).

After installing the drivers testdisk detects them both as 3TB (yay). It seems to be ok detecting the partitions.
test.jpg
First
test.jpg (251.23 KiB) Viewed 538 times
I ran a quick search. 8 hours later I got a series of random partitions (apparently normal?) with only 1 being 3000GB. After picking that one I looked and it showed the correct "name" of the drive (yay). Thinking I had it in the bag I selected that, hit P to view the files expecting to start a file-dump to my handy external backup drive....and only 1 file was detected correctly (from the root directory if I remember correctly).

Back to the forums...I saw that maybe I need a deeper search. It is currently searching. By my stopwatch and count rate its got 30 hours to go (364800 cylinders at about 1/2 sec each).

I am assuming (and hoping) that the lack of drivers didn't destroy the data but simply confused the file-system/partition.

As someone else said most of the instructions are for single drives and not RAID.
I want to know if there is anything weird I need to do when it finishes?
I would prefer not to have to restart a 48-hour search if I hit the wrong button (or worse lose the data).
I am also second-guessing myself (did I maybe make it RAID0 by accident?).

I will try to post some screen-grabs once it finishes scanning if I don't accidently quit (which I did once after the quick scan).

----Update----

Deep scan had same results. Detects the "named" partition but not all the files.
Named.jpg
Named
Named.jpg (121.99 KiB) Viewed 538 times
Only a single file then the same file repeated at 0 size with no directories. I copied the single file succefussly but I'm looking for the others (thousands no doubt). I tried to go to each of the detected partitions to see if any of the junk ones had the files, but somehow got dumped to the main menu after looking at a bad one. I must not understand the menu system for testdisk, is there a menu tree-somewhere?

The log is really long at this point...but when I go to list the files (the point where what I am seeing doesn't match the step-by-step guides) it says:
"ntfs_readdir failed for cluster 5"

I foolishly thought my data was safe :(
Any help is greatly appreciated!

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests