Recovering a Lost EXT4 Partition

How to use TestDisk to recover lost partition
Post Reply
Message
Author
skeledrew
Posts: 1
Joined: 02 Jul 2014, 05:11

Recovering a Lost EXT4 Partition

#1 Post by skeledrew » 02 Jul 2014, 05:56

Hi,

I have a 1TB HDD which was split in 3 roughly equal parts of 333GB. The first had Zorin OS installed and was formatted EXT4. The second was /home and also EXT4, and the third /windows and FAT32. I accidentally started installing Kubuntu, which had marked the entire disk as one partition, and I aborted the install after a couple seconds. However, I lost my partition info, and have been trying to recover via testdisk.

So far I was able to recover my FAT32 partition from the deep search. However, there are many entries for the EXT4 FS, and none of the ones I tried had a valid FS even though the size is correct. Also "sudo e2fsck -b <block> -B 4096 /dev/sda" gives the error "e2fsck: Bad magic number in super-block while trying to open /dev/sda". However, I'm positive the files are still there because the install only went for a short time and photorec has already recovered over 250,000 files. I just need some way to get the file structure repaired for the second partition. The first isn't important since I'm planning on reinstalling anyway. Here's the link to my testdisk.log file. Thanks in advance.

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests