Win7 corrupted my SD card

Using PhotoRec to recover lost data
Post Reply
Message
Author
rbirch
Posts: 1
Joined: 16 Jul 2014, 15:41

Win7 corrupted my SD card

#1 Post by rbirch » 16 Jul 2014, 15:55

Just got back from a week backpacking in Yosemite, and i was going through my photos in Windows Photo Viewer and rotating the images i'd taken in portrait mode. Trying to write back the rotated images, Windows had an error writing to the SD card. After ejecting and re-inserting the card, the date-stamped directories created by the camera all appeared as file icons, and all of the JPG files were gone. :-(

Trying PhotoRec... i ran once with the default settings and got 10 photos back (These were the ones i'd actually rotated and Windows had re-written them.) i ran PhotoRec again in expert mode, bruteforce, and blocksize=512, and i started to get more older long-deleted pictures that i recognized. But after several hours PhotoRec hung and was not making any more progress. (My guess is that is was a memory issue... i have 100s of firefox tabs open.)

i closed all apps, rebooted, and tried again several times (i think with the same settings i'd used the second time when i started seeing more old pictures) but all i'm getting now is the same 10 initial photos that i got with the default settings. i can't figure out what i'm doing differently.

Can anyone help?

(Also, i've seen someone else mention cloning the SD card to the hard drive first and running the recovery on that cloned image to speed up the run time. How do i do that? In the TestDisk doc i don't see any mention of cloning a disk image.)

Thanks in advance!!

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests