HFS on MacMini +Fusion Drive, harddisk seems too small.

How to use TestDisk to recover lost partition
Post Reply
Message
Author
siwi
Posts: 1
Joined: 02 Aug 2014, 11:03

HFS on MacMini +Fusion Drive, harddisk seems too small.

#1 Post by siwi » 02 Aug 2014, 11:28

Dear all,

My mac mini with fusion drive doesn't boot up anymore. I already tried several things in order to repair it ( including 'gpt' actions, what I exactly did is reported on the apple forum: https://discussions.apple.com/thread/58 ... 0&tstart=0 , I am user simowil , there are also images attached on the current status. )

Over last night I run the TestDisk tool analysis and made a deep search.
It reports that there is not enough disk space left.

Code: Select all

The harddisk (1000 GB / 931 GiB) seems too small! (< 7020022 TB / 6384673 TiB) Check the harddisk size: HD jumpers settings, BIOS detection...
.. similar to what I get when I tried to add the partition with gpt add

Code: Select all

gpt add: disk0: error: no space available on device
Some background infos:
- Mac mini (Late 2012), OS X Mountain Lion (10.8.5), Fusion Drive with 1TB HD + 128GB SSD
- TripleBoot with Mac, Windows and Ubuntu using rEFIt.
- The mac mini was running for weeks, or even months before. Was not turned off, only went to sleep. I noticed on my apple laptop that this can result in huge swap files in /private/var/vm/
- Before rebooting the system I tried to install the latest OS X version (10.9.4). After downloading the package, the installer asked me on which partition it should be installed. It didn't recognize the Ubuntu partition, which is totally fine. Bootcamp and Mac partition were found BUT BOTH WERE DECLARED AS UN-BOOTABLE. This surprised, I expteced at least my Mac partition as bootable. So I aborted the installation of 10.9.4 and tried to reboot. Which indeed didn't work and which is the situation I am currently in.

Any help is highly appreciated!
Thanks in advance!

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests