Help with recovering failed RAID 0: Error 0xAA55

How to use TestDisk to recover lost partition
Post Reply
Message
Author
Alphaminor
Posts: 1
Joined: 11 Aug 2014, 12:39

Help with recovering failed RAID 0: Error 0xAA55

#1 Post by Alphaminor » 11 Aug 2014, 16:13

Hi! First time poster. I have tried to search this problem on this board and elsewhere but not finding any solution. The situation is as follows:

I have 2 WD Green disks in a RAID 0 system, controlled by the on-board Intel chipset on the mobo Asus Z87-Deluxe. The controller managed by Intel Rapid Storage Technology accessible during boot by pressing ctrl + I. Anyway, the problem is that one of the two disks suddenly was "non-member" during boot and the raid array was "failed". I googled this and found this page: http://www.overclock.net/t/478557/howto ... disk-error

This described exactly my problem, and a solution to it by re-creating the RAID with the same settings as before and then using TestDisk to write the fixed partition table. It worked like a charm, and TestDisk found my partition and files in a few seconds.

BUT today one of the disks appeared as non-member again! I did the exact same routine again, but this time when I started up TestDisk i got the error: "Partition sector doesn't have the endmark 0xAA55" and no partition found during quick search. I'm currently doing a deep scan, but so far nothing on 78%.

The disks look to be unharmed hardware wise, but something has happened since I can't recover and I don't know how to proceed. Any help i appreciated. Thanks

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests