Testdisk 7 (win32) freezed while copying from image

How to use TestDisk to recover lost partition
Post Reply
Message
Author
petsol
Posts: 2
Joined: 15 Aug 2014, 11:38

Testdisk 7 (win32) freezed while copying from image

#1 Post by petsol » 15 Aug 2014, 12:08

First of all I would like to thank you very much for this program. I - like many others - tried to refresh my ubuntu insallation and this shameful installer created one huge partition overwriting my windows and data partitions. Thanks to your software and some 30 hours of work I found the partitions, and I see all data in them.

I am working from an image from 2nd sector (i couldnt figure how can I make a whole disk image), but it seems to be working, i find the partitions after selecting correct geometry (WD10JPVT 16h 63s 512b).

Now I move on a huge directory to copy it, and it starts to copy. However I observed two strange behaviours:
after a while the copy stalls, and freezes the whole system, or it begins to rewrite the same file again and again.

I will try linux. Before I try to restore partitions I have to copy everything.

I don't know if its a bug, or it is something with my system.

Also I can't quit from the program, when it doesnt hang the whole system (not even task manager comes up). (press q)

Sponsored links

petsol
Posts: 2
Joined: 15 Aug 2014, 11:38

Re: Testdisk 7 (win32) freezed while copying from image

#2 Post by petsol » 16 Aug 2014, 16:33

This freezing is apparent under linux version 6.14 too. Maybe its specific to this recovery or some hardware I have.

However by coping out smaller chunks I was able to recover ALL of my personal files, or files I deemed necessary to copy. I can't be thankful enough for this program...

If you copy file by file, or smaller dierctories it wont freeze.

One other thing I observed, the linux and the windows version works a bit differently (may be the version) in Linux I was able to open only one partition, while in Windows I was able to copy from both. So Try both if you are desperate. The key to find my data was to find out correct geometry. WD was not helpful, they don't publish it, I found it in a polish blog. Of course you might ask them (WD).

Another thing is to make an image. Don't attemp to work with the drive, make an image copy, if you can.

User avatar
cgrenier
Site Admin
Posts: 3497
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Testdisk 7 (win32) freezed while copying from image

#3 Post by cgrenier » 16 Aug 2014, 17:12

Can you try TestDisk 7.0-WIP for Linux ? It uses a more recent version of libntfs-3g than 6.14 (TestDisk 6.14 and 7.0-WIP for win32 uses libntfs from ntfsprogs 2.0 instead).

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 0 guests