Partition on WD Elements overwritten by Androidx86 live cd

How to use TestDisk to recover lost partition
Post Reply
Message
Author
gmc85
Posts: 2
Joined: 09 Aug 2014, 17:15

Partition on WD Elements overwritten by Androidx86 live cd

#1 Post by gmc85 » 19 Aug 2014, 17:11

Hi all

So a couple of weeks ago I tried running Androidx86 of a LIVECD , it didn't work so I rebooted to winxp.
And then when I tried to download something to my ext drive(WD Elements 1T USB2.0) I was denied access. The name was like generic "local disk" which was weird. So I rebooted to Linuxmint 17 and the drive didn't even show up in file manager and in gparted it showed just one ext2 partition with the name "Android-x86" across the entire drive.

Rebooted back to xp , looking around the net I found testdisk. At first quick search found a linux partition, the deep scan found everything including the NTFS partition. but when I pressed "p" there were no files. So I tried chkdsk /r and it worked, most of the files were back (some were in a folder "found") and the name of the drive was correct "Elements".
So I thought problem solved - wrong. The linux partition was still there, covering the same space as the NTFS. Trying to fix it with testdisk didn't work. I could still access files and folders in windows.

So the only option to really fixing this mess was to copy everything (around 380 gigs) somewhere else and repartitioning the drive in gparted. But I dind't have enough space. Then a couple of days ago my neighbor gave me his old pc which is newer than mine and has more hdd space. So now i have enough drive space (3x160gigs) to copy everything. But now on this newer pc with freshly installed win7 the ext drive is once again "Access denied". I tried chkdsk /r again but nothing.

What do i do? What would happen if I went to gparted on mint and simply deleted the ext2 partition?

testdisk still shows files and folders on NTFS.

I need help, please.

Sponsored links

gmc85
Posts: 2
Joined: 09 Aug 2014, 17:15

Re: Partition on WD Elements overwritten by Androidx86 live

#2 Post by gmc85 » 26 Aug 2014, 11:19

I got it. I can just copy files from the disk with testdisk. Thanx for pointing that out to me. :lol:

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests