Partition and/or file recovery on QNAP TS-451

How to use TestDisk to recover lost partition
Post Reply
Message
Author
kieranu
Posts: 1
Joined: 20 Aug 2014, 02:48

Partition and/or file recovery on QNAP TS-451

#1 Post by kieranu » 20 Aug 2014, 03:59

I have a QNap TS-451. After migrating to this NAS (Intel Celeron) as it supports larger volumes I experienced intermittent performance problems which may be at least partially because the system wasn't installed from scratch. Anyway, one effect of this was my config information got lost so login settings etc were reset and the RAID wasn't mounting. After I managed to recover this my RAID-5 array wouldn't mount because there was a slight discrepancy between the number of blocks being reported by the file system and the superblock. Information I received later indicates that this was possibly because I didn't specify a chunk of 64 rather than the default 512. Since most of the data was backed up and my attempt to mount was proving fruitless and running e2fsck seemed to be doing more harm than good I ended up resetting the NAS config which had the effect of reformatting the RAID (disks in the same order).

Since I heard about testdisk and photorec before I start copying data back to the volume I want to check if it is possible to attempt to recover data from the previous incarnation of the array using testdisk or photorec (things I'm most concerned about are documents (Excel, Word, PDF, etc). I tried this with the x86_64 version 7.0 of testdisk and photorec but upon execution of either I get a permission denied error. I attempted to execute using sudo but an error reports there is no root user. Attempting to create a root user in QNAP management reports that this user is reserved for system use.

I will try again with version 6.14 tonight to see if this makes a difference, but I appreciate any information you can provide me.

Thanks

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests