Attempting MAC partition recovery. /dev/sda?? *HELP*

How to use TestDisk to recover lost partition
Post Reply
Message
Author
Sktchwlkr
Posts: 2
Joined: 20 Aug 2014, 18:26

Attempting MAC partition recovery. /dev/sda?? *HELP*

#1 Post by Sktchwlkr » 20 Aug 2014, 18:49

First and foremost, I never had to deal with programs like this or using some sort of command prompt, so be patient with me.

So I'm trying to recover my MAC partition but have run into a few problems along the way. I run Windows via Bootcamp, which is the only bootable device at the moment besides an OS X install CD I had laying around. Since I'm unable to boot to MAC, obvious, I can only run TestDisk in the Windows partition. One possibly important thing I noticed is that instead of >Disk /dev/disk1 or /dev/rdisk1, it reads /dev/sda(where the MAC partition is located). Most of the recovery examples in regard to MAC partitions do not read /sda. Is that a weird thing?
Anyways,I proceeded through the steps and documented all the important information needed for Terminal.
I'm using Terminal right off the install disk since there's no way to access the one on the OS X, if that makes sense.

1. I type: sudo pdisk /dev/sda. It said sudo command not found. I assume that I actually don't need that command since I'm already running as administrator? correct me if I'm wrong.
2. (THE PROBLEM) I type: pdisk /dev/sda. It says No such file or directory. Therefore I'm unable to continue.
-I have no idea what the heck is going on or what to do.

Do i need to run testdisk from the MAC partition somehow?
Is it important that I'm using terminal right off the install disk?
What is sda and is that a problem?

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3458
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Attempting MAC partition recovery. /dev/sda?? *HELP*

#2 Post by cgrenier » 20 Aug 2014, 20:21

Mac partition table were used on Mac using PowerPC processor, it means machine 10 years old or more.
More recent Mac uses EFI GPT partition table, so no need to use pdisk.

Sktchwlkr
Posts: 2
Joined: 20 Aug 2014, 18:26

Re: Attempting MAC partition recovery. /dev/sda?? *HELP*

#3 Post by Sktchwlkr » 20 Aug 2014, 21:26

If using pdisk is of no use, then what do I do?

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests