PhotoRec - 7.0 WIP - Error - Linux x86_64

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 2
Joined: 27 Aug 2014, 02:44

PhotoRec - 7.0 WIP - Error - Linux x86_64

#1 Post by jsloan2 »

First off... this tool is saving my ass, thanks so much!

Second, thought I should let you know about an error
Using PhotoRec from the WIP produces an error after an undetermined amount of time, crashes back to CLI with the following:
PhotoRec syntax error: ,inter

[/share/USBDisk1/recovery] # ../testdisk-7.0-WIP/photorec_static /version
PhotoRec 7.0-WIP, Data Recovery Utility, August 2014
Christophe GRENIER <>

Version: 7.0-WIP
Compiler: GCC 4.4
Compilation date: 2014-08-20T21:45:05
ext2fs lib: 1.42.8, ntfs lib: libntfs-3g, ewf lib: 20120504, libjpeg: libjpeg-turbo-1.2.0
OS: Linux, kernel 3.4.6 (#1 SMP Thu Jun 12 02:38:33 CST 2014) x86_64

Posts: 1
Joined: 26 Jan 2015, 09:54

Re: PhotoRec - 7.0 WIP - Error - Linux x86_64

#2 Post by walef »


I encountered the same after photorec had scanned my 20 TB XFS for about 200 hours. It found lots of files!
Where does this come from and what does it mean?

I called: /tmp/testdisk-7.0-WIP/photorec_static /d /mnt3/ /mnt/dumpdata1
OpenSuSE 13.2 kernel 3.16.7-7-desktop

Posts: 1
Joined: 31 Aug 2016, 08:11

Re: PhotoRec - 7.0 WIP - Error - Linux x86_64

#3 Post by nlomb »

First of All ...
testdisk / photorec is a great tool, thanks ...

I'm getting the same error after recovering a lot of files (130GB)

PhotoRec syntax error: ,inter

same disk to recover, photorec started on ubuntu 16.04 (32 & 64 Bit)

don't know what this means and how to workaround

User avatar
Site Admin
Posts: 5427
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: PhotoRec - 7.0 WIP - Error - Linux x86_64

#4 Post by cgrenier »

This message occurs (after session restart has been used) with old version of Photorec when the recovery is finished. You can ignore this message.