Cannot read external harddisk WD MyBook

How to use TestDisk to recover lost partition
Post Reply
Message
Author
miramas
Posts: 1
Joined: 16 Sep 2014, 07:27

Cannot read external harddisk WD MyBook

#1 Post by miramas » 16 Sep 2014, 07:42

I'm on a 64 bits windows desktop. OS W7. External Harddisk (WD MyBook 1,5 TB) cannot be read anymore. I can see the drive in mycomputer (H:) I have run analysis test with testdisk-6.14 .

My questios are:

1. I would like to recover photo files (if possible other data too, but photo files are the main thing).
2. Could anyone help me out interpreting the analysis report an where to go from here?
3. AT one point I was able to list the maps and files with testdisk-6.14 on the drive. Tried to copy those files but result was: 0 ok 151 failed.

I would be very pleased if anyone could help me out.

Sponsored links

DorianWD
Posts: 15
Joined: 17 Sep 2014, 08:50

Re: Cannot read external harddisk WD MyBook

#2 Post by DorianWD » 17 Sep 2014, 09:30

Hi there, I am really sorry to hear about your issue. If I understood correctly, you are able to see the drive in My Computer but you are unable to open it? If this is the case what happens when you double click on it?

I would suggest that you run Data Lifeguard Diagnostics (DLG) and see if there is an issue with the hard drive. You can download it from the WD website: http://support.wdc.com/product/download ... =3&lang=en

Regards,
Dorian_WD

TitaniaWD
Posts: 4
Joined: 19 Sep 2014, 12:50

Re: Cannot read external harddisk WD MyBook

#3 Post by TitaniaWD » 19 Sep 2014, 15:02

Hello @miramas,
I know you're worried about your photos and files. The Data Lifeguard Diagnostic (DLD) that @DorianWD suggested will not only check the health of your drive, but may repair some corrupted files.
It is possible that if you unplugged the device unsafely or something interrupted the connection to the PC, this caused some corruption to your files.
If I were you, I'd go through the basic troubleshooting first- try the drive on a different USB port, with a different cable, may be on a different Computer, just to rule out some options. If nothing helps and the DLD indicates a lot of corrupted files, then you can look for some free Data Recovery Software on the Web, or seek the help of the specialists.
Here is a list of the Western Digital Data Recovery Partners – http://support.wdc.com/recovery/index.a ... wdsfMyBook.
Let me know if this helps,
Titania_WD
http://www.wdc.com

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests