Recover Ext3 partition after FAT format from CF

How to use TestDisk to recover lost partition
Post Reply
Message
Author
TheFox
Posts: 2
Joined: 17 Feb 2013, 19:38

Recover Ext3 partition after FAT format from CF

#1 Post by TheFox » 18 Sep 2014, 18:09

Hey,
I am trying to help a friend that has some embedded system which includes an Ext3 partition (that contains some propriety Linux dist) on a 2GB CF card.
He wanted to upgrade the FW on the CF and inserted the CF to his Windows7 machine which asked to format the drive, he accidentally formatted the CF card to FAT.
Looks like some data was written to the FAT partition by someone.

I ran Testdisk on his CF card using Intel partition table type and quick analyze found a FAT partition at sector 0 and an Ext3 partition from sector 1 and onwards (don't remember the end sector).
It fits since the Fat partition in windows was showing ~9MB in size.

I was able to see the files and even backup the Ext3 partition, I managed to delete the FAT partition using Diskpart in windows and using TestDisk mark the Ext3 partition as Primary bootable but the booloader (GRUB) in his embedded machine was unable to boot from it (just stuck at screen saying: GRUB).

Is it possible to recover the Ext3 partition completely ? did the FAT format override the content on sector 0 which the Ext3 partition was (maybe) using ?

I don't have the CF card at the moment but I did make a full backup of the partition in .dd format.

help will be much appreciated.
Thanks :)

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest