File Recovery from an old Laptop hard drive Topic is solved

Using PhotoRec to recover lost data
Locked
Message
Author
kucher12
Posts: 2
Joined: 08 Nov 2014, 23:34

File Recovery from an old Laptop hard drive

#1 Post by kucher12 » 09 Nov 2014, 00:17

Hello,

Here is the situation. I had an old laptop, it recently died, not hard drive failure (my lunchpack leaked) and after i shut down the computer - i could never turn it on again. I cleaned it in and out - to no avail, it just doesn't turn on. Not sure what was exactly had happened. But anyway, it was 5 years old - i bought new MBP. All i want is to get my files back from the old laptop hard drive.

It's seagate 500gb 5400 rpm.

It has 4 partitions:
1 for system - 100gb
2 for media - 150gb and 250gb (roughly)
recovery partition which was made by when I installed windows 8.1 on it few months ago - like 100 mb

Long time ago, when I was partitioning for the first time I turned them all into Dynamic Drives. Yeah, i didn't know...
So basically today I bought the disk enclosure and connected it first to a PC in the store where I bought the enclosure. in the Disk Management it didn't recognise it, it was marked as "Inavalid". I came home, connected it to my mac. In Disk Utilities I can see 4 partitions, but they are unreadable by default. I installed TUXERA NTFS for Mac, as it claimed to be able read NTFS-3G (which as i understood was synonymous to dynamic disks).

Tuxera was able to read only the system partition "C" drive with all the folder structure, etc. Just like i would see it in Explorer in Windows. I don't really need that much from C drive, apart from few files. It also recognised and was able to mount system recovery partition. The other two with the most important data - it couldn't mount and read.

When I put "diskutils list" in the terminal thats what it gives me:

/dev/disk2
#: TYPE NAME SIZE IDENTIFIER
0: FDisk_partition_scheme *500.1 GB disk2
1: Windows_LDM 1.0 MB disk2s1
2: 0x27 12.0 GB disk2s2
3: Windows_LDM System Reserved 104.9 MB disk2s3
4: Windows_LDM 107.4 GB disk2s4

Now what is very strange to me is why partition sizes are so weird?
4: Windows_LDM 107.4 GB disk2s4 - this one is definitely the system drive that i have been able to access as well as the System Recovery:
3: Windows_LDM System Reserved 104.9 MB disk2s3

What happened with other 2 partitions, and why it shows 1 MB and 12.0 GB - i dont know. they should be 250 and 150.

I found TestDisk tutorial that it can change dynamic disks back to primary without messing the data and i wanted to use it for these purposes. Now, I did everything according to this instruction: http://www.allroundgeek.com/2011/05/sav ... sk-to.html

I ran few times TestDisk and it stucks at "Analyse Sector 693895168/976773165: 00%" I just closed terminal and started it all over again, just to get stuck at the same point.

It has been about an hour so far like that, stuck.

And I have a few questions:

1. Shall I just let the tool continue to run, or if it stuck - its probably an error, it wont go through?
2. Is there another way perhaps to get the data from the remaining two partitions extracted? If yes - how?
3. I have another hard drive which has like 590gb free - cloning the whole drive would be a good option? And is it going to clone the file structure as well? Or will it be like an image of the drive?

Here is the screen just in case, of where I am atm.

Image

Let me know if you need some additional info.

Hope you can help me out.

Regards,
Aleks

Sponsored links

kucher12
Posts: 2
Joined: 08 Nov 2014, 23:34

Re: File Recovery from an old Laptop hard drive  Topic is solved

#2 Post by kucher12 » 09 Nov 2014, 19:28

Update:

I stopped once more the the whole process of scanning after few more hours of not moving.

Restarted. Launched TestDisk and changed the geometry: 255 heads 63 cylinders.

After that Analyse function has done its job within 10 seconds. Found all partitions, including the 2 other missing ones. They were listed with Logical disk label (which is a mystery for me, why). I left it to copy my partitions on the laptop.

In the morning - i noticed an error - that the startup disk was full (although i made sure I had enough space before starting copying process). Basically my hard drive was packed full. Copy didn't finish.

I decided to let TestDisk let do the analysis again and change partitions to primary. Process was done in no time, I rebooted - and was able to read every single partition. Data was intact.

Just finished copying all the data to the external drive. But noticed after that my laptops drive was half full! Practically I didn't understand how it was possible as its 2 weeks old.

So if anyone encounters the same problem - use this tool: OmniDiskSweeper (mac)

It scans the drive very quickly and shows you biggest folders/files on it (you can also remove them with this tool). I found that testdisk.log was 198.9 GB large, (woooot?! :))

Simple delete worked very well - mystery solved.

Anyway guys thank you just for having this forum and such a tool like TestDisk - I wouldn't fix my problem otherwise.

Cheers!
Aleks

Locked

Who is online

Users browsing this forum: No registered users and 4 guests