Help please! Can I change the logical sector size somehow?

Using TestDisk to repair the filesystem
Post Reply
Message
Author
JQCoburn
Posts: 2
Joined: 13 Nov 2014, 18:31

Help please! Can I change the logical sector size somehow?

#1 Post by JQCoburn » 13 Nov 2014, 22:32

Hey guys, I could really use some help here as I'm in way over my head.

I've got a 3TB drive that is failing. It was formatted with GPT table with a 500GB Mac HFS partition and a 2.5TB exFAT partition. I bought another 3TB drive to replace it from a different manufacturer. I ran ddrescue for several days and it was able to read/clone everything except for a few Kb around the 1565-1566GB mark and when I finially killed it, it was down to 29 errors spread through that area.

After ddrescue finished I thought I should be able to just see the cloned disk now since it cloned the partition map too, but Windows 7 says I need to format it before I use it and Ubuntu doesn't list it at all in the file browser (I'm using Ubuntu Live to recover) I thought maybe the partition map had become corrupted so I launched testdisk and did the following:
  • Quick search using the default settings. When it started it gave me some chk_fat warnings about heads or cylinders or something not matching. The quick search was taking forever so I let it run over night. When I came back this morning, It had found a small EFI/GPT partition, a ~500 GB Mac HFS partition, a ~250 GB MS partition, a couple really small MS partitions, and then a gigantic MS partition that it told me it could not recover because my drive was smaller than 1000 something TB. I quit that analyze session without writing or doing a deep search.
  • Then I noticed that testdisk was using a default sector size of 512 but the original disk had a sector size of 4096. So I changed testdisk's sector size to 4096 and then as soon as I selected analyze the 3 partitions I was expecting (small EFI/GPT partition, 500GB Mac HFS partition, 2.5TB MS partition) all showed up along with their original names. I ran a quick search that finished immediately finding only a 3TB NTFS partion that was on the disk when I bought it. I was thinking it would give me the option to write partition map containing the 3 partitions instead of the partition map with just the single NTFS partition.
  • I then started a Deep search hoping it would give me the option to write the 3 partition partition map instead. I'll see what progress it has made when I get home tonight.
As a side note, when I run fdisk -l it tells me that the new disk has a sector size of 512/4096(logical/physical) and that the partitions don't align to sector boundaries. The old disk shows a sector size of 4096/4096(logical/physical). This has me wondering if my partition map is fine and the trouble I'm seeing is the fact that the new disk is showing a smaller sector size. So is it possible to change the logical sector size on a disk? If so how so? I'm a newb in the hard disk recover world, but I can find my way around a computer handily enough.

As a side question, is it possible for ddrescue to have changed the disk geometry? I can't say for certain, but I thought that before I ran ddrescue, the new disk had a slightly different geometry than the old one, but now the geometries are much more similar. The only differences I can find are the number of cylinders (old is 40,000 something, the new is 37,000 or 38,000 something) and the logical sector size. When using ddrescue, I did use the --sector-size=4096 and --force options.

Sorry if this is verbose. Like I said I new at this and I'm not sure what information would be helpful.
Thanks for the help!
Josh

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest