Ext4 FS -- Files visible but can't repair parition

How to use TestDisk to recover lost partition
Post Reply
Message
Author
sweenepj
Posts: 1
Joined: 24 Nov 2014, 01:41

Ext4 FS -- Files visible but can't repair parition

#1 Post by sweenepj » 24 Nov 2014, 01:51

Here's the backstory... I physically moved a 2TB ext4 hard disk from an Ubuntu system to a Windows 7 system. I foolishly went into the Windows Disk Management and when it "stat"ed the drive it apparently overwrote my partition table. For a while the disk just looked like unallocated space.

Through a bunch of troubleshooting, I am now able to view the partition and files inside testdisk (thank goodness). I can even recover the files manually, so I'm not in seriously dire circumstances (i.e. my wife will not kill me for losing her files).

However, I feel like I should be able to recover the partition table now and I'm wondering if I'm missing something. When I run testdisk I have to select "None" for the partition table type, otherwise it won't find the ext4 partition. After selecting "None" I can go into "Advanced" and view/recover the files OR do "Analyze" and it will find the partition. This is excellent; but it won't let me "write" a partition table because I have selected "None" as the partition table type.

Is there any way to remedy this? The files are there and I can recover them, I just wish I should fix the partition table and be done with it.

Thanks for any assistance!

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests