RAID 5 failure after CMOS reset

How to use TestDisk to recover lost partition
Post Reply
Message
Author
jp3544
Posts: 1
Joined: 06 May 2012, 14:40

RAID 5 failure after CMOS reset

#1 Post by jp3544 » 06 May 2012, 15:27

My CMOS was reset (system stored in move and CMOS battery died). Windows booted *before* I had a chance to set the BIOS back to [RAID]. I did not initialize or format any drives in Windows, and quickly disconnected the power. I rebooted and changed to RAID mode, but it had 2 of the drives as non-member

Raid was created on a ASUS Sabertooth X58 LGA 1366 with chipset Intel ICH10R.
1x1 TB OS Drive ((Windows 7 x64)
Intel Matrix Storage Manager ROM 8.0.0.1038 ICH10R wRAID5
3 x 1.5TB Raid 5
Note: in OS only partitioned a portion of the array to leave reserve space (I had originally provided 2TB and extended to 2.5 TB)

Just 1 drives correctly remains identified as "Member Disk." The 2 other drives were reset to "Non-Raid

I am following instructions found from: http://forums.extremeoverclocking.com/s ... ?p=3329132 which others have referred to as well.
1) Go into the Intel Matrix Storage Manager in BIOS.
2) Mark all the drives in the RAID as "non-Raid."
3) Re-Create the RAID using the SAME settings as the original RAID that you are trying to recover.
Since drives were not changed, I assumed the disk order was correct. I set the same configurations
Raid Name: Data
Raid type: RAID 5
Block Size: 128K
4) I ran testdisk and was able to analyze the disk, but selected the options attached in the screenshot

I selected INTEL instead of EPI-GPT even though they stated this was detected (Raid was created through the BIOS)
I let this run, however I am generating these errors for invalid FAT Boot Sector.

This should be correct since there is not an MBR. This quick scan is taking quite some time. I just want to verify I selected the correct options and let it run its course or do I need to select start over and select EPI GPT

Thanks in advance, I appreciate any help.
Attachments
testdisk3.JPG
results while still scanning
testdisk3.JPG (41.47 KiB) Viewed 1312 times
testdisk2.JPG
Selected Intel as option
testdisk2.JPG (50.12 KiB) Viewed 1312 times
testdisk1.JPG
selecting recreated RAID volume
testdisk1.JPG (48.08 KiB) Viewed 1312 times

Sponsored links

User avatar
remy
Posts: 457
Joined: 25 Mar 2012, 10:21
Location: Strasbourg, France.
Contact:

Re: RAID 5 failure after CMOS reset

#2 Post by remy » 09 May 2012, 23:41

Your raid volume is independent of the filesystem and partition table you put over.

Your raid controller create the raid5 3TB, and the you format it. So, as far as this volume is > 2TB, it's probabely an EFI/GPT table.

You should scan with EFI/GPT table or "None" if you want to verify.
J'ai pour habitude d'aller au bout de l'aide que j'apporte. Si vous pensez que je vous ai abandonné, et que je ne l'ai pas fait explicitement, c'est que votre message est enfoui avec d'autres. Relancez-moi (modérément) par mail.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests