RAID 5 recovery

How to use TestDisk to recover lost partition
Post Reply
Message
Author
N3St
Posts: 2
Joined: 27 Jan 2015, 00:38

RAID 5 recovery

#1 Post by N3St » 27 Jan 2015, 00:46

Hi all,

I hope I did not miss a topic describing this problem, but here goes nothing.

I have an MSI z87-g45 Mobo with 3 WD HDD's in a RAID 5 configuration through Intel RST. I had to use the CMOS button due to a failed attempt at OCing and because the SATA setting went back from RAID to AHCI the controller lost track of my discs. I followed the fora and reset all of the discs to non-raid members, and afterwards I created a new RAID volume with the same settings as the previous one.

Now Testdisk recognizes my partitions if I choose the Intel partition scheme, even though Testdisk's default value is CGI EFG (or something like that). Under the latter it does not recognize everything and it says that one partition is invalid. Under the Intel partition scheme, everything looks OK, with the exception that I can't select all of the partitions to be primary partitions without Testdisk showing the "Structure: Bad" sign (see picture).

Is there anyone who has experience with this and could offer some advice on how to proceed?
Attachments
TestdiskIntelPartitionview.JPG
Testdisk Intel Partition overview
TestdiskIntelPartitionview.JPG (60.68 KiB) Viewed 763 times

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3419
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: RAID 5 recovery

#2 Post by cgrenier » 27 Jan 2015, 08:08

With a PC Intel partition table, you can't exceed 4 partitions entries. One can be an extended partition that can hold several Logical partitions. In your case, you should let one partition as D(eleted) or select EFI GPT.

N3St
Posts: 2
Joined: 27 Jan 2015, 00:38

Re: RAID 5 recovery

#3 Post by N3St » 27 Jan 2015, 10:58

Thanks cgrenier!

In case I select EFI GPT option I run into the following two situations (I am currently not at my pc so I cannot upload a picture, but maybe the description will suffice)

- Testdisk does not recognize the right size for the lowest partition in the list (Media) and says that the found partition size exceeds the disk size. Could I be that I made an error in redefinition of the block size for the RAID array?

- Testdisk shows me several partitions more than I actually had on the array, so I am not quite sure how to proceed from there. Could I just try something out without inflicting irrecoverable damage on the MBR?

Best regards

Post Reply

Who is online

Users browsing this forum: Google Adsense [Bot] and 0 guests