Am I doing this right?

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 9
Joined: 20 Mar 2015, 19:12

Am I doing this right?

#1 Post by lonrot »

I'm trying to recover a single 4 TB ExFat partition made in Maverick's Disk Utility.

This single partition on the disk has storage files shared between Windows and Mac.

It became inaccessible after a Windows performed a repair reboot on the main hard drive.

Here's what TestDisk has found:

1) Disk selection (Note: disk0 and rdisk0 have the same size!)


2) EFI GPT detected on Disk0. Is this okay for an exFat partition?


3) MS DATA found! The sector size reflects the 4 TB storage. Is this a green light?

User avatar
Site Admin
Posts: 5422
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Am I doing this right?

#2 Post by cgrenier »

In Advanced, select the partition and choose List or Undelete or Boot/List.

You can try

Code: Select all

sudo fsck.exfat /dev/disk0p1
or something similar

Posts: 9
Joined: 20 Mar 2015, 19:12

Re: Am I doing this right?

#3 Post by lonrot »

Christophe the partition is back, however Windows mistakenly tried to "repair" the hard drive during boot, and now it shows up as a Windows primary partition even though it does not have an OS.

Is there a way to get rid of this leftover MBR data and remove the drive from the boot list?