Running Testdisk Wi Acttive CD

How to use TestDisk to recover lost partition
Post Reply
Message
Author
BudTuba
Posts: 1
Joined: 04 Apr 2015, 15:55

Running Testdisk Wi Acttive CD

#1 Post by BudTuba » 04 Apr 2015, 16:29

I recently reinstalled Win Vista on my dual boot laptop. It did not warn that ALL partitions would be removed, but I did. make sure it was installed on a separate partition from the bulk of the hard drive. This was verified by the size of the windows partition vs the hard drive capacity. However, my Ubuntu 14.10 system and all files were gone, as well as swap partition and a separate data partition. I tried Gparted to see what was there, but even to veiw files or rescue data, it required the command line 'gpart'. I could not figure out how to do that when I discovered Testdisk. I downloaded the linux i386 version with intention to add it to my USB containing the active CD. I did not have enough administration privileges.. I moved Testdisk to the root directory and tried sudo install, etc. but everything boils down to there is no root password for the active CD version of Ubuntu. I am going to try the Windows version of Testdisk on the Vista OS. To get the files there I used Google+ so I can download once logged on.

Boy, if you could make a version and explicit instructions of using it, :shock: that could be added to the LIVE CD and run from there, it would make life much easier for people who encountered the same kind of problem when the Windows installation erases the Linux partitiaons.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3499
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Running Testdisk Wi Acttive CD

#2 Post by cgrenier » 05 Apr 2015, 09:31

On Ubuntu or Debian Linux, use "sudo -s" to get root

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests