WD 2T Corrupt MFT

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 23 Apr 2015, 07:32

WD 2T Corrupt MFT

#1 Post by kracken74 »

I use an Western Digital 2T as a internal backup disk. It contains only media files and no Operating System.
Last night I had a message about corrupted MFT from Windows 8. (the disk is formatted as NTFS). I ran the CHKDSK from Dos (as suggestion from Microsoft's site) but nothing happened.
The only change is now that windows prompt me to FORMAT the disk.

Today also ran the MBR fix from cgsecurity but I couldn't start.
While I'm writing this post, I analyse the disk with the utility that comes with the TestDusk, and it found this:
Invalid FAT Boot Sector
0 D FAT12 41939 112 19 133012 167 9 1463091201
FAT12 41939 112 19 133012 167 9 1463091201

Since I have no idea what to do next, could someone help me?

Thanks in advance!

User avatar
Posts: 2835
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: WD 2T Corrupt MFT

#2 Post by Fiona »

Please don't run chkdsk etc.. to avoid any changes to your file system.
Invalid FAT Boot Sector
Boot sector repair would be possible?
Please run another diagnose through Analyse, Quick and if nothing is found Deeper Search also.
If partitions are found, please mark the them and press p to have a try to list your files.
Copy and paste the content of your testdisk.log into your next post.