Recover XFS partition

Using TestDisk to repair the filesystem
Post Reply
Message
Author
dmi2
Posts: 1
Joined: 15 May 2015, 12:29

Recover XFS partition

#1 Post by dmi2 » 16 May 2015, 09:10

Hi!

I bought a upgrading kit for my computer last week, motherboard and CPU. I moved my RAID-6(dm-crypt/LUKS with XFS) to the new motherboard. And after that, I have been having trouble to assemble the RAID.

I tried to assemble the disk with "mdadm --assemble --scan -v", but all the disks complained about "mdadm: no recogniseable superblock on /dev/sdX". So I moved the disks back to the old motherboard, but I got the same result when I tried to assemble the raid.

After spending some time on google, I found out that you can re-create the array without initial re-sync
After several of hours of on google, i tried to assembly the raid with --create and --assume-clean.

So I tried instead to re-create the raid with --assume-clean, and it worked.

mdadm --create --assume-clean --level=raid6 --chunk=256 --raid-devices=5 /dev/md1 /dev/sda /dev/sdb /dev/sdc /dev/sdd /dev/sdf

And the next step was to decrypt the raid, and it also worked.

cryptsetup luksOpen /dev/md1 data


But when I tried to mount it, it failed, with "wrong fs type, bad option, bad superblock on..."

mount /dev/mapper/data /mnt/data

mount: wrong fs type, bad option, bad superblock on /dev/sdb,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

I also tried with adding -t xfs, but it didnt help.


After spending some time on google, I found this thread http://hardforum.com/showthread.php?t=1476237


I ran xfs_repair, and after that I could mount the partition, but total used space was 1%, instead it should be 99%. All the data is not there!


However, I ran PhotoRec and was able to recover some media, so the data is still there, but "hidden" in some way. I don't have enough disk storage to save the data from PhotoRec, so before I buy more disks, and want to check if there is something more I can try with?

Did I mess up the XFS metadata or is there any chance to recover the old XFS partition?

/David

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests