Recovery of resources inside of file?

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 1
Joined: 07 Jun 2015, 13:13

Recovery of resources inside of file?

#1 Post by hmijail »


I have a file which embeds other files. More specifically, it is the resource fork from an old Macintosh application. This kind of files embed other files, which can be sounds, images, etc, in different formats. And I am trying to use Photorec to recover those "embedded files".

But when I run "./photorec myfile" in Mac OS X 10.10.3, it answers "Unable to open file or device myfile: Inappropriate ioctl for device".

I have not managed to get any different result nor further info by using /debug, /log nor /d.

So I have 2 questions:
1.- what do I have to do to have photorec open a file?
2.- looks like photorec will try to guess a block size to only look for file signatures in the block starting points. But I don't know if resource forks have any kind of internal padding or alignment which would put individual resources in any kind of block boundaries. So, does photorec stand a chance of finding the individual resources?