RAID 5 mit 10 HDs 2 defekt

TestDisk benutzen um verlorene Partitionen wiederherzustellen
Post Reply
Message
Author
chrisy
Posts: 1
Joined: 11 Jun 2015, 14:48

RAID 5 mit 10 HDs 2 defekt

#1 Post by chrisy » 11 Jun 2015, 15:03

Hallo,

ich bin in einer ziemlich misslichen Lage. Vielleicht kann mir jemand auf die Sprünge helfen, weil mir etwas nicht klar ist.

Habe eine QNAP mit 10 HDs, zwei sind defekt, oder als solche markiert. Das Raid 5 ist "soweit" intakt.
Personalities : [raid1] [raid6] [raid5] [raid4] [linear] [multipath] [raid0] [raid10]
md321 : inactive sdj5[0](S) sdi5[1](S)
16707560 blocks super 1.0

md256 : active raid1 sde2[8](S) sdh2[7](S) sdj2[0] sdg2[6](S) sdf2[9](S) sdi2[1] sdb2[4](S) sda2[5](S)
530112 blocks super 1.0 [2/2] [UU]
bitmap: 0/1 pages [0KB], 65536KB chunk

md0 : active raid6 sdj3[6] sdh3[0] sdf3[9] sdi3[7] sdg3[1] sde3[8] sdb3[2] sda3[3]
31176507392 blocks super 1.0 level 6, 512k chunk, algorithm 2 [10/8] [UUUU__UUUU]
bitmap: 0/30 pages [0KB], 65536KB chunk

md126 : active raid1 sdh1[7] sdj1[0] sde1[4] sdg1[6] sdf1[5] sdi1[1] sdb1[2] sda1[3]
530048 blocks [10/8] [UUUUUUUU__]
bitmap: 65/65 pages [260KB], 4KB chunk

md127 : active raid1 sdh4[7] sdj4[0] sdf4[5] sdi4[1] sdg4[6] sde4[4] sdb4[2] sda4[3]
458880 blocks [10/8] [UUUUUUUU__]
bitmap: 49/57 pages [196KB], 4KB chunk

unused devices: <none>
Nur, auf dem Teil /dev/md0 ist kein(!) Dateisystem. Nun habe ich mit photorec versucht, von /dev/md0 einige Dateien zu retten, jedoch kommen nur kleine Files unversehrt heraus und Datenmüll.

Auf md0 ist die Chunkgröße 512k, was darauf deuten würden, dass die kleine Dateieinheiten rekonstruiert werden können, aber große Dateien (ab 0,5 MB) eben nicht. Ist die Reihenfolge der HDs falsch?

Vielleicht hat die zuständige Person, eine Neuinitialisierung des Raids :evil: mit geänderter Reihenfolge durchgeführt? Habe ich eine Möglichkeit dies über testdisk herauszufinden?

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests