UFS archive disk unreadable

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Locked
Message
Author
TheOptimist
Posts: 2
Joined: 26 Jun 2015, 23:49

UFS archive disk unreadable

#1 Post by TheOptimist »

Dear filesystem guru,

I have discovered an offsite backup of work that I'd forgotten about, from four years ago. It would be great if I can access the data on it because it contains a lot of valuable materials that I thought were lost forever.

The 1TB disk came out of a Freenas 7.XX server which runs on FreeBSD and is formatted UFS.

When I put it into my current Freenas server it complains with the following error:


I put the disk into a Win 7 machine and Disk Manager reports it as a 298.09 Primary Partition (not 1TB).

I ran testdisk, please see the attached log.

Please advise if you suspect a possibility of recovery.

Thanks in advance

Nigel Haslam
Attachments
testdisk.zip
(79.46 KiB) Downloaded 191 times

Sponsored links

TheOptimist
Posts: 2
Joined: 26 Jun 2015, 23:49

Re: UFS archive disk unreadable

#2 Post by TheOptimist »

Hi,

I realized that I hadn't posted the message from Freenas in the above post so I put the disk back into my server and lo and behold, it allowed the disk to be mounted.

Thanks for your consideration

Nigel

Locked